Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Computer Displays
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-07-2018, 04:34 PM   #1
PopcornMobo
Member
 
PopcornMobo's Avatar
 
Join Date: Dec 2017
City & State: Lithuania
My Country: Lithuania
Line Voltage: 220-240 VAC @ 50 Hz
I'm a: Knowledge Seeker
Posts: 40
Default AOC 2216Sa monitor displaying weird colors.

I found this monitor at the dump right when i was in the need of one.
The monitor is not smashed and works fine.
The lack of "LED" stickers on it tells me that it's got CFL in it.
One thing about it is that it's displaying colors wrong.
It's like there's these very rough transitions between various shades of colors, almost as if there's only about 32 colors.
Also every second vertical line of pixels is darker where the image is also dark.
The only example to describe this i can think of would be maybe a compressed image.
Now that i think of it i also have a TV that also displays colors in the exact same way and that TV also happens to have CFLs in it.
I remember something similar to this happening on my SONY laptop, it had a failing CFL tube in it and would occasionally display the image wrong, i bodged a LED backlight from another screen in it and it's been working fine ever since, could this be related?
One bad thing about this screen is that it's a pain to take apart, the plastic from the back comes off easily but the PCB is behind a sheet metal frame that is attached to the LCD assembly, this prevents me from easily checking the caps.
Another thing is that the aforementioned TV does the same thing but all the caps in that one are good.
My guess is that the CFLs are old and the HV drivers are working overtime and in turn end up causing EMI, which then messes with the image processing.
I can kind of sort of try to take a picture of the screen to show what it looks like.

Any ideas?
Attached Images
File Type: jpg P_20181008_013903.jpg (807.0 KB, 11 views)

Last edited by PopcornMobo; 10-07-2018 at 04:49 PM..
PopcornMobo is offline   Reply With Quote
Old 10-07-2018, 04:47 PM   #2
petehall347
Badcaps Veteran
 
Join Date: Jan 2015
City & State: worcester
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 1,702
Default Re: AOC 2216Sa monitor displaying weird colors.

phone camera might get a good pic .
petehall347 is online now   Reply With Quote
Old 10-07-2018, 04:54 PM   #3
PopcornMobo
Member
 
PopcornMobo's Avatar
 
Join Date: Dec 2017
City & State: Lithuania
My Country: Lithuania
Line Voltage: 220-240 VAC @ 50 Hz
I'm a: Knowledge Seeker
Posts: 40
Default Re: AOC 2216Sa monitor displaying weird colors.

Quote:
Originally Posted by petehall347 View Post
phone camera might get a good pic .
I updated the original post.
It's hard to get a decent picture of a screen without aliasing, but the one i got looks good enough.
The red in the windows logo shows the dark vertical lines well and the blue shows the bad transitions between shades of colors.
It's like the screen is trying to display the image in a compressed/low-bit mode.

Last edited by PopcornMobo; 10-07-2018 at 04:56 PM..
PopcornMobo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 06:43 PM.
Did you find this forum helpful?