Badcaps.net Forum
Go Back   Badcaps Forums > Motherboards with Bad Capacitors > All Others Motherboards
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 09-19-2014, 12:32 PM   #1
orientalsniper
Badcaps Veteran
 
Join Date: Apr 2013
City & State: Florida
My Country: USA
I'm a: Knowledge Seeker
Posts: 377
Default ASRock Z77 Extreme 6 not powering up

Hello, I could use some help trying to fix this motherboard, so I get 3.4V in PWRSW and I also shorted the PSU to feed power to motherboard by force and I don't feel any heated part.

Could the problem be in the SIO chip or southbridge/northbridge?

UPDATE:

Only 5V in PIN9 (+5VSB) and 5V in PIN16 (PSU_ON#) of PSU connector.

Last edited by orientalsniper; 09-19-2014 at 12:54 PM..
orientalsniper is offline   Reply With Quote
Old 09-19-2014, 01:33 PM   #2
ReeceyBurger123
Never Give Up !
 
ReeceyBurger123's Avatar
 
Join Date: May 2014
City & State: Telford
My Country: Britain
Line Voltage: 240 VAC 50Hz
I'm a: Student Tech
Posts: 7,118
Default Re: ASRock Z77 Extreme 6 not powering up

Lets rule out the psu first, do you have another psu to check the board with ?
ReeceyBurger123 is offline   Reply With Quote
Old 09-19-2014, 01:35 PM   #3
orientalsniper
Badcaps Veteran
 
Join Date: Apr 2013
City & State: Florida
My Country: USA
I'm a: Knowledge Seeker
Posts: 377
Default Re: ASRock Z77 Extreme 6 not powering up

Yeah, I've tried different PSU/processor/RAM.
orientalsniper is offline   Reply With Quote
Old 09-19-2014, 02:05 PM   #4
ReeceyBurger123
Never Give Up !
 
ReeceyBurger123's Avatar
 
Join Date: May 2014
City & State: Telford
My Country: Britain
Line Voltage: 240 VAC 50Hz
I'm a: Student Tech
Posts: 7,118
Default Re: ASRock Z77 Extreme 6 not powering up

Ok sounds like something on the board, firstly check the board all over for any shorted pins for example on the pci slots if there is nothing obvious then I will tell you what to check next.
Also check things like the usb ports and ram slots, we need to narrow this down.

Last edited by ReeceyBurger123; 09-19-2014 at 02:09 PM..
ReeceyBurger123 is offline   Reply With Quote
Old 09-19-2014, 02:16 PM   #5
orientalsniper
Badcaps Veteran
 
Join Date: Apr 2013
City & State: Florida
My Country: USA
I'm a: Knowledge Seeker
Posts: 377
Default Re: ASRock Z77 Extreme 6 not powering up

Yeah, man, I already checked those: USB, SATA, Firewire, LAN, HDMI, PCI, PCIe, RAM.
orientalsniper is offline   Reply With Quote
Old 09-19-2014, 02:28 PM   #6
orientalsniper
Badcaps Veteran
 
Join Date: Apr 2013
City & State: Florida
My Country: USA
I'm a: Knowledge Seeker
Posts: 377
Default Re: ASRock Z77 Extreme 6 not powering up

Checking resistance with ATX power connector against ground:

3.3V: 265 ohms
5V: 515 ohms
12V: 3 kohms
orientalsniper is offline   Reply With Quote
Old 09-19-2014, 02:46 PM   #7
ReeceyBurger123
Never Give Up !
 
ReeceyBurger123's Avatar
 
Join Date: May 2014
City & State: Telford
My Country: Britain
Line Voltage: 240 VAC 50Hz
I'm a: Student Tech
Posts: 7,118
Default Re: ASRock Z77 Extreme 6 not powering up

Sounds like a short, firstly check the cpu vrm mosfets as they normally go first check all the mosfets for resistance just check them all and see if any of them check different from the majority of them.
ReeceyBurger123 is offline   Reply With Quote
Old 09-20-2014, 12:32 PM   #8
orientalsniper
Badcaps Veteran
 
Join Date: Apr 2013
City & State: Florida
My Country: USA
I'm a: Knowledge Seeker
Posts: 377
Default Re: ASRock Z77 Extreme 6 not powering up

Sorry, what do you mean by resistance? Gate/Source/Drain against ground?

I did test the coils near the vrm mosfets and so far it's not shorted against ground though.
orientalsniper is offline   Reply With Quote
Old 11-13-2014, 01:47 PM   #9
david38c63
New Member
 
Join Date: Oct 2011
Posts: 4
Default Re: ASRock Z77 Extreme 6 not powering up

I would start looking for bad caps that esr is too high on in the 3.3v supply and 5 volt stand by
david38c63 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 01:24 AM.
Did you find this forum helpful?