Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Appliances and other Household Electronic Stuff
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-19-2023, 01:32 AM   #1
Use2bavolvo
New Member
 
Join Date: Jan 2023
City & State: Burnaby,bc
My Country: Canada
I'm a: Knowledge Seeker
Posts: 11
Default Magic chef oven - thermistor ref voltage issue

I am having an issue with my wall oven temperature control is ~180f out of spec. The thermistor is measuring correctly but I noticed the ref voltage appears to be off. With the thermistor wires attached it's reading ~3.4vdc with the thermistor disconnected it's around I9.8vdc. my understanding is the temp is read off the resistance from the thermistor which leads me to believe the issue is with the ref voltage.

Another observation is the temp setting and readout at lower temps is way off meaning the oven thinks room temp is 300f and bake relay doesn't engage unless temp setting is much higher..

Anyone have any thoughts on what's going on? I plan on rreplacing the caps this thing is 30yo.

I've also I'd a fan resistor that's not registering any ohms ATM the fan runs all the time so not sure if that's also causing the issue.
Attached Images
File Type: jpg IMG_20230114_223045_118.jpg (359.9 KB, 11 views)
File Type: jpg IMG_20221126_090755_429~2.jpg (495.5 KB, 16 views)
File Type: jpg IMG_20221126_090819_076.jpg (433.4 KB, 15 views)
Use2bavolvo is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2023
Powered by vBulletin ®
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 01:46 PM.
Did you find this forum helpful?