Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Game Consoles & Other Weird Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 12-19-2022, 08:08 PM   #1
supravit2000
New Member
 
Join Date: Aug 2021
City & State: sofia
My Country: bulgaria
I'm a: Knowledge Seeker
Posts: 4
Lightbulb PS4 fat has inconsistent signal after HDMI replacement

Hi, guys!

I am not a professional, all I can do is solder stuff on the boards, so I would really appreciate it if someone with knowledge shares his experience/thoughts on a problem I have with a PS4 console.

My friend gave me an original fat PS4, board model SAB-001, with WLOD, that has been previously opened. I changed the HDMI port, couple of pads on the board were ripped, which I connected to the corresponding caps/resistors? Just did so as in a shown diagram (one of the ground pads I ripped off and left it not connected). However, there was still no signal, so I checked the hdmi fuse, which was blown - replaced it with a fuse from SAA-001 board (that one has BLOD). Still no picture, so I replaced the HDMI IC from that same board and 2 HDMI filters as well. Replaced one resistor and a diode too (I think), which I saw on a repair video by Andrew Paul. Then the signal was fine, played for half hour, all good.

After a couple of weeks I turned the console on and there was the WLOD again. On safe mode it fired up, I changed the resolution to 1080i, since on 1080p there was no signal. The colors were weird, but picture was present. I tried another cable - with that one 1080p worked, but all the whites on the screen were with snowy artifacts as well as the left corner. So I hot-aired the HDMI ic in order to solder any loose joints, and this time it worked fine on 1080p. I thought it was finally OK, so reassembled the unit.

However, after turning on the console, it would go blank screen for a minute or two, then the signal comes back. Works fine for a couple of hours, then goes black/no signal for good. After power off/on again, the same thing happens - the signal randomly drops couple of times, then comes back and cuts out properly after a while.

I would really appreciate if somebody with proper knowledge/experience has any idea what causes this issue. Many thanks!



https://drive.google.com/file/d/1HWN...6CKylK5ag/view
supravit2000 is offline   Reply With Quote
Old 12-19-2022, 11:32 PM   #2
diif
Badcaps Veteran
 
Join Date: Feb 2014
City & State: Midlands
My Country: England
I'm a: Professional Tech
Posts: 6,584
Default Re: PS4 fat has inconsistent signal after HDMI replacement

Check each pin is soldered well by giving them a little push.
diif is offline   Reply With Quote
Old 12-20-2022, 06:08 AM   #3
CapLeaker
Leaking Member
 
CapLeaker's Avatar
 
Join Date: Dec 2014
City & State: Atlantic Canada
My Country: Canada
Line Voltage: Ground, 0Hz
I'm a: Hobbyist Tech
Posts: 5,558
Default Re: PS4 fat has inconsistent signal after HDMI replacement

try a can of air upside down and start freezing stuff.
CapLeaker is offline   Reply With Quote
Old 12-20-2022, 05:50 PM   #4
supravit2000
New Member
 
Join Date: Aug 2021
City & State: sofia
My Country: bulgaria
I'm a: Knowledge Seeker
Posts: 4
Default Re: PS4 fat has inconsistent signal after HDMI replacement

Quote:
Originally Posted by diif View Post
Check each pin is soldered well by giving them a little push.
all the pins are solid, mate :/ I even have a HDMI tester and everything goes where it should on a male plug. 10x for the advice, though!

@CapLeaker - I am not familiar with that freezing stuff, haven't got a clue what it's all about.. but thanks for checking!
supravit2000 is offline   Reply With Quote
Old 01-04-2023, 02:16 PM   #5
supravit2000
New Member
 
Join Date: Aug 2021
City & State: sofia
My Country: bulgaria
I'm a: Knowledge Seeker
Posts: 4
Default Re: PS4 fat has inconsistent signal after HDMI replacement

Quote:
Originally Posted by diif View Post
Check each pin is soldered well by giving them a little push.
Thanks a million, mate! I've fixed it, thanks to your advice!

For anybody having the same problem - it seems that the Panasonic HDMI ic had a pin loose. I nearly broke it when testing.. It's not that easy to spot a loose connection on the chip, so be careful.
supravit2000 is offline   Reply With Quote
Old 01-04-2023, 02:53 PM   #6
diif
Badcaps Veteran
 
Join Date: Feb 2014
City & State: Midlands
My Country: England
I'm a: Professional Tech
Posts: 6,584
Default Re: PS4 fat has inconsistent signal after HDMI replacement

I'm glad you've found the issue.
diif is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2023
Powered by vBulletin ®
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 09:25 AM.
Did you find this forum helpful?