Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Game Consoles & Other Weird Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 12-25-2019, 01:33 PM   #1
Jesse James
Member
 
Join Date: Sep 2018
City & State: Ontario
My Country: Canada
I'm a: Hobbyist Tech
Posts: 84
Default Opus BT-C3100 2.2 Problem

Hello all. I am not sure if anyone is familiar with this lithium Ion charger. I have had discharging issues that turned out to be cracked solders for the discharge resistors. This is a 4 bay charger and tester with mah load test. The problem I am having is now bay 2 and 4 will not charge or discharge at all. It goes through all the steps as if it was working but my voltage never changes.
I have tested resistors and diodes and also tried to compare a good working bay with the non working bay but am at a loss.
Any help would be great
Attached Images
File Type: jpg Opus-BT-C3100-V2.0-Intelligent-Battery-Charger-Review-and-Teardown_8180.jpg (632.2 KB, 45 views)
File Type: jpg LKkace7.jpg (343.6 KB, 27 views)

Last edited by Jesse James; 12-25-2019 at 01:36 PM..
Jesse James is offline   Reply With Quote
Old 12-25-2019, 06:10 PM   #2
stj
Great Sage 齊天大聖
 
stj's Avatar
 
Join Date: Dec 2009
City & State: Europe
My Country: some shithole run by Israeli agents
I'm a: Professional Tech
Posts: 28,106
Default Re: Opus BT-C3100 2.2 Problem

complete pcb pictures would help.
i didnt know the opus did a load test, i thought only the Litokala did that. - interesting to know.
stj is offline   Reply With Quote
Old 12-30-2019, 07:44 PM   #3
CapLeaker
Leaking Member
 
CapLeaker's Avatar
 
Join Date: Dec 2014
City & State: Atlantic Canada
My Country: Canada
Line Voltage: Ground, 0Hz
I'm a: Hobbyist Tech
Posts: 5,558
Default Re: Opus BT-C3100 2.2 Problem

each channel has it's own step down converter on the other side.
https://www.youtube.com/watch?v=JJxrDgEFxMU
CapLeaker is offline   Reply With Quote
Old 01-17-2020, 11:16 AM   #4
Jesse James
Member
 
Join Date: Sep 2018
City & State: Ontario
My Country: Canada
I'm a: Hobbyist Tech
Posts: 84
Default Re: Opus BT-C3100 2.2 Problem

Thanks for the help guys. As far as I can tell the step down converters are ok. I am thinking the gate voltages are wrong on my AO3400A mosfets (not sure) but I think the voltage varies on the amount of charge determined so it confuses me. All I know is at any setting 200ma-1000ma three of the four bays are only charging 30-40ma on my volt meter and when selecting discharge I am getting 0.
Attached Files
File Type: pdf AO3400A.pdf (471.1 KB, 9 views)

Last edited by Jesse James; 01-17-2020 at 11:17 AM..
Jesse James is offline   Reply With Quote
Old 01-17-2020, 12:00 PM   #5
stj
Great Sage 齊天大聖
 
stj's Avatar
 
Join Date: Dec 2009
City & State: Europe
My Country: some shithole run by Israeli agents
I'm a: Professional Tech
Posts: 28,106
Default Re: Opus BT-C3100 2.2 Problem

fets are voltage not current driven,
maybe there is a bad resistor somewhere - or the computer is running at the wrong clockspeed - fucking the PWM up.
stj is offline   Reply With Quote
Old 01-17-2020, 12:09 PM   #6
Jesse James
Member
 
Join Date: Sep 2018
City & State: Ontario
My Country: Canada
I'm a: Hobbyist Tech
Posts: 84
Default Re: Opus BT-C3100 2.2 Problem

Ok thanks. If I do find anything I will post it here. Who knows maybe someone else will run into this someday.
Jesse James is offline   Reply With Quote
Old 11-16-2022, 02:13 AM   #7
Francesc V.
Tempus fugit
 
Join Date: Nov 2022
City & State: Masquefa
My Country: Catalonia
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 68
Default Re: Opus BT-C3100 2.2 Problem

Hi:

This is the summary I've been facing on this charger so far.

Discharge problems:
- Replace the six 5.1R SMD resistors from the affected slot. They use to burn after long use.

Charging problems:
- Check step down converter might be the issue.

Wrong Voltage reading:
- I am having a slot that reads about the half of the voltage when inserting the battery. I am investigating it.......but so far with no success. If somebody might have an idea, I would appreciate it.

Regards,
Francesc.
Francesc V. is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2023
Powered by vBulletin ®
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 08:42 AM.
Did you find this forum helpful?