Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Computer Displays
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 07-20-2018, 09:38 AM   #1
tofubazille
New Member
 
Join Date: Apr 2013
City & State: Vienna
My Country: Austria
I'm a: Knowledge Seeker
Posts: 9
Default DELL U2412Mb - defective Logic Board, black screen, backlight on

Hi!
I've got a problem with my DELL U2412Mb. The logic board has been grilled via USB in a power outage, all caps had 0Ohms and some SMD components were grilled.
Only option was to buy a new board.

I've got another working DELL U2412Mb here, so before I ordered a board from ebay, I cross checked which part is broken with parts from my other working monitor and it is the logic board. There's no chance that it is a power board, panel/Tcon or cable problem, I tested the components with the display controller from my other monitor and the setup is working like a charm.

Unfortunately there seems to be a problem with the used logic board I bought on ebay. I built it in and tested it but there is no signal on the LVDS cable. The backlight lights up but the screen stays black, it doesn't show a "no signal" message or anything else. When I press the "Input" button on the monitor, the backlight turns off for a second and turns on again which is the expected behavior, so the board doesn't seem to be 100% bricked.

The fuses on the logic board F1 to F5 are all fine. In another thread some guy said that it could be a problem with the signal that tells the panel to switch on. I found two voltage regulators on the board, a DH (?) 61-12 and a DH 17-33. My first idea would be to measure the voltage on the output of the regulators, does that make sense as a first step?

I want to wait until I've got a statement from the seller who said that the board has been taken from a working system. I'm from the EU and the seller is from the States, so there is only a little chance of a return.

Video Board: 4H.1GH01.A10
Panel: Samsung LTM240CL01

Thanks and best wishes
Tofu
Attached Images
File Type: jpg 20180720_172705.jpg (1.13 MB, 15 views)
File Type: jpg 20180720_172518.jpg (883.4 KB, 13 views)
File Type: jpg 20180720_172513.jpg (707.2 KB, 8 views)
tofubazille is offline   Reply With Quote
Old 07-20-2018, 11:10 AM   #2
tofubazille
New Member
 
Join Date: Apr 2013
City & State: Vienna
My Country: Austria
I'm a: Knowledge Seeker
Posts: 9
Default Re: DELL U2412Mb - defective Logic Board, black screen, backlight on

Though both Logic Boards have the same model number AND same revision there is a minimal difference: on my working board there is no SMD resistor of 1.2kOhm (R103, the one with 152 written on it) connected to the Vin pins 28,29,30 of the LVDS connector. What's the reason?

Oh, another difference... at position R144 there is a 0Ohm resister on the new board, on the working board it is placed at R143. Looks like the Logic Boards are using different voltages for the panel!

Last edited by tofubazille; 07-20-2018 at 11:35 AM..
tofubazille is offline   Reply With Quote
Old 07-20-2018, 11:41 AM   #3
tofubazille
New Member
 
Join Date: Apr 2013
City & State: Vienna
My Country: Austria
I'm a: Knowledge Seeker
Posts: 9
Default Re: DELL U2412Mb - defective Logic Board, black screen, backlight on

The picture in the attachment shows the 0Ohm resistor.

Edit: Ok, just switched positions of the 0Ohm resistor and removed the 1,5kOhm Resistor and .... the monitor is back to life! Problem solved!

Just for clarification: The PCB layout is indeed 4H.1GH01.A10 but the assembly is 5E1GH01004 for the 5V panel and 5E1GH01005 for the other voltage. The assembly version is written on a small sticker in the back of the PCB.
Attached Images
File Type: jpg 20180720_193001.jpg (677.4 KB, 16 views)

Last edited by tofubazille; 07-20-2018 at 12:29 PM..
tofubazille is offline   Reply With Quote
Old 07-24-2018, 09:52 PM   #4
sixstringartist
New Member
 
Join Date: May 2012
City & State: TX
My Country: USA
I'm a: Knowledge Seeker
Posts: 11
Default Re: DELL U2412Mb - defective Logic Board, black screen, backlight on

Good work. Looks like that logic board was targeted at multiple different displays.
sixstringartist is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 08:24 PM.
Did you find this forum helpful?