View Single Post
Old 01-14-2022, 03:06 PM   #10
Dannyx
CertifiedAxhole
 
Dannyx's Avatar
 
Join Date: Aug 2016
City & State: Constanta
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Hardcore Geek
Posts: 3,248
Talking Re: Axis Q6034-E Speed Dome cam No Power (teach me about POE)

Today I tried powering the board after the caps as previously planned. By accident, I came across a post on EEVBlog where a chap was having an almost identical issue with an almost identical camera. His symptoms were exactly the same, so I was REALLY curious if he managed to get it going, but sadly the thread died half-way through and it was never solved. I replied anyway just to see if there will be a follow-up, but I doubt it.

However, I did get one interesting piece of info out of it: the guy had the same idea and powered the camera after the PoE part by applying power directly to the output caps. He said he tried 19v and the camera started, so I did the same. I wasn't as lucky though: mine does nothing....well, almost nothing: the tiny fan on the dome itself spins briefly then stops....that's it. Sh!t - I was afraid I may have more problems in the head itself, but I decided to stay calm and not throw in the towel just yet. See, it could be one of the downstream converters IS indeed faulty, despite having no shorts that I could find outright, which tells me something must be failing when powered, like an IC getting "stuck on", but ONLY when power is applied. I decided it's time to reverse-engineer this thing a bit and focus on the rest of the board, not just on the PoE section, as much as I hoped I wouldn't have to, because it's multi-layer, so it's not fun to work with...

I wanted to see how "VIN" (B+ so to say) actually goes INTO the converters, but I wasn't getting a direct connection between the positive leg of those small output caps and the input pins of the ICs (there's 3 switching converters, so 3 ICs, 1 of which is different to the rest - THIS one, an LM5576).

Turns out VIN must first go through a transistor before getting to the converters: it's this SOT23 transistor near this large "152" resistor in the picture. It's labeled 610ZT and I couldn't find anything about this part right away. Google however, based on my search, somehow DID stumble upon an Ali listing for a part that looks identical, so I looked up the datasheet for that one and although it could very well be a different part entirely, the pinout seems to match: you've got the Gate pin where the small black resistor is, 4 Drain pins to the right (2 on both sides, which act as the "output" ) and 1 Source pin (bottom left from "R010" current sense resistor there, which acts as the "input").

There's also the current sense resistor and that LTCWK part: the LTCWK is THISso if my theory is correct, VIN arrives through the CS resistor, through the transistor's S and finally out through D to the 3 converters. Since there's a fault somewhere after the resistor, the LTCWK IC detects overcurrent and shuts off the transistor, hence why the fan briefly spins then stops and I get no boot. The next step is to:

A) gently inject power from my bench supply even deeper into the board. In fact, directly into those 2 solder joints in the picture which by the way correspond to GND and VIN AFTER the transistor, connected to the D pins, so the "output" of the transistor so to say.

B) check to see what/IF the 3 converters output anything (provided I can sustain power) or what goes pop if I start pumping some amps there. This being after the CS resistor, LTCWK has no way of stopping that now and I can at least blow up what's at fault I think I'm getting close to cracking it
Attached Images
File Type: jpg 20220114_201739.jpg (417.0 KB, 11 views)
__________________
Wattevah...
Dannyx is offline   Reply With Quote