View Single Post
Old 01-01-2013, 04:57 PM   #8
momaka
Badcaps Veteran
 
momaka's Avatar
 
Join Date: May 2008
City & State: VA (NoVA)
My Country: U.S.A.
Line Voltage: 120 VAC, 60 Hz
I'm a: Hobbyist Tech
Posts: 8,935
Default Re: Need help with Shuttle SB83G5A - fans spin but that's all

And another update for this thread (if anyone cares, lol ).
.
.
I bought a replacement RT9203 controller from eBay. Since the gate trace to the upper MOSFET was ripped on the board, I decided I might as well just kludge it with a DPAK MOSFET (I have quite a few of them). Ended up using a 60N02 MOSFET (25V, 62A, 8.4 mOhm Rds_on). Pictures of the handy work are attached below . Yeah, I know... as usual. The braid soldered to the MOSFET's tab is its heat sink and holder, BTW .

Surprisingly when I powered it on, nothing smoked . However, the motherboard is still dead as a stone . I checked the voltage output of the NB buck regulator and it's putting out 1.44-1.45V. That seems pretty close to the required 1.5V for the NB, don't you think?

Also, now that the NB voltage rail is present, all of the other major voltage rails are present too. Before this, the CPU Vcore and RAM VTT were not present along with a few other voltage rails. So looks like there IS some progress after all.

CPU Vcore is at 1.57V, though. Isn't that a bit high? FYI, CPU is a 2.8 GHz Pentium 4 (socket 775, Prescott??). I just looked on CPU-World website and all Pentium 4 for the socket 775 are rated for up to 1.4V. So something looks wrong here I think . Caps on the CPU VRM low side seem fine though (there's 4x 6.3V 3300uF Ost RLS and 8x 4V 560uF Sanyo SEPC polymers). If anything, those polymers should be keeping everything stable. In addition, I added an extra 4V 820uF Fujitsu FP-CAP RE series, so I think there shouldn't be any excess ripple on the CPU VRM output.

Lastly, I tried a POST card. Doesn't look like the BIOS is trying to boot at all (POST card stays at "00"). Normally, the POST card will display some numbers as the BIOS is going through the POST process. CPU fan is still blowing on full blast (it's PWM controlled and should slow down if POST is successful).

Another abnormality I noticed is that the first few times I tried the computer after I put in the MOSFET and the RT9203 buck controller is that the POST card indicated that the PSU 3.3V rail was not present and the NB voltage was only showing 1.34V (unless I made an error measuring with my multimeter). I then connected the PCI-E auxiliary power connector on the motherboard (it's a 4 pin floppy connector) and on the next boot, the POST card indicated that the PSU 3.3V rail was present and the NB voltage rail came up to 1.45V. Ever since then, it doesn't matter if I have the PCI-E auxiliary power connected or not - PSU 3.3V rail on the POST card always shows up as present and the NB voltage rail has been fine since then too. Coincidence or weird occurrence?

So, any ideas? I believe I have tried pretty much everything on this motherboard. The only few things I could still try is a new CPU, replace the NB, and maybe reflash the BIOS or replace it altogether. Out of these 3, though, only replacing the CPU seems something I can do. I can't replace the i915 NB because I don't have another one (unless someone here has a dead board with one and doesn't mind pulling it off), and I don't have a BIOS flasher. So if anyone has any ideas, it'd love to hear them. I don't need this computer badly or anything, but it would be nice to have and also good learning experience (+ highly rewarding for my mind since I've done so much work on it ).
Attached Images
File Type: jpg Suttle XPC FB83 (7).jpg (316.5 KB, 70 views)
File Type: jpg Suttle XPC FB83 (8).jpg (273.7 KB, 59 views)

Last edited by momaka; 01-01-2013 at 05:06 PM..
momaka is offline   Reply With Quote