View Single Post
Old 07-30-2018, 09:08 AM   #102
vidua
New Member
 
Join Date: Nov 2014
City & State: Zürich Zürich
My Country: Switzerland
I'm a: Knowledge Seeker
Posts: 4
Post Re: No Power Dell U2410 Monitor

This thread is still alive after more than 3 years! I finally managed to repair my Dell U2410f. Sweet victory


In short, the parts i had to replace:

FR851 fusible resistor 0.2 Ohms
Q853 power transistor STF15NM60N
U850 PFC / DC DC combination chip SG6901
U930 L7575 DC DC converter chip
D856 1N5406
Q953 MMBT2907


I started a long time ago to repair my U2410f and finally succeeded, so i may be not 100% correct in what i say but here is my story.

I got my monitor from a scrap yard and was curious if i could repair it, so this was not an urgent job and now i finally did it.

When i opened it i first saw a blown fuse resistor FR851 0.2 Ohms and measured a shorted Q853 power transistor STF15NM60N for the PFC, the usual thing reported here before. I replaced them. Nothing changed, no supply voltages.

I checked U930 L7575 and came to the conclusion that it should work but it didn't. So i exchanged this one as well.
From then on i had power on the video board but the screen remained black and the blue lamps for the power and settings buttons stayed off.

I have 230V here and i remarked that the DC link voltage over C874 remained at ~326Vdc which means that this is just the rectified mains voltage and the PFC which is a boost/step-up circuit does not work. If it would have worked the voltage would have been going up clearly over 326Vdc.

I was not sure if my U850 SG6901 had to work at the measured supply voltage so i fed it externally with an isolated supply but still nothing, no driving pulses going to PFC transistor Q853. I decided to exchange this one as well.

No change. I had to see that the supply voltage of the PFC IC U850 remained below start conditions and searched for the reason. I found out that U930 L7575 which is generating the power for the video board also generates an auxiliary voltage which feeds itself (U930) and the PFC U850. The L7575 fed itself but i had to see that the power for U850 SG6901 was not fed and found that Q953 MMBT2907 a PNP transistor was broken and not forwarding the supply voltage to the PFC SG6901 U850.

I exchanged Q953 and i got the blue lamps on the front side going on with a beep for the first time. Also the DC link voltage over C874 was rising over 326V now for the first time but turned off repeatedly shortly afterwards in "hiccup" mode. I noticed that D856 1N5406 got warm.

For this test i had 500W filament bulb lamps connected to the 230Vac supply in series as an overcurrent protection and they lit up which means there still was a problem, the 500W power up consumption was way too high.
I also noticed that the DC link voltage on C874 never went higher than 326V though the PFC part of the U850 SG6901 was switching, i did not understand why.

I checked the D856 1N5406 diode which got warm outside the board but found nothing and soldered it back in and tried again. This time after only one start procedure the diode started smoking and broke down with a short. I did not understand but i replaced it.

I checked the stuff around it but everything seemed OK. I tried again and now the hiccup was gone and even the LCD backlight turned on (this one is generated by the DC DC part of U850 SG6901). Everything was fine! It ran continuously without problem from then on.

The breakdown of D856 is really mysterious as i have never seen anything similar. From my point of view there are two possibilites what happened: A) the forward voltage of the diode got too high. I never saw something like that but it would give a reason why the temperature of the diode got too high. What i see is that power diodes short but do not create more forward voltage after a failure. But this does not explain why the voltage of the step up circuit was not rising. B) The diode couldn't keep the blocking voltage and started to act like a Zener diode after it got partially damaged. This would explain the heating and the impossibility for the DC voltage to rise over 326Vdc. It would also explain that my simple diode check still showed it to be "OK". So B) is my favorite explanation.

Now the sad end of the story: the screen is made from multi layer glass. After the back light turned on i was able to see that the inner glass layer was broken while the outside looked perfect...

I hope this helps anyone who wants to repair a U2410f, just ask if you have questions, have fun.

Last edited by vidua; 07-30-2018 at 09:27 AM..
vidua is offline   Reply With Quote