View Single Post
Old 11-03-2017, 07:49 AM   #1
piernov
Badcaps Veteran
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 693
Default MSI B75MA-E33 (MS-7808) and W25Q128BV BIOS

This is the second time I need to flash the BIOS on my board and I also had to do it one time on a friend's (same model, same batch since I ordered 2).
My friend's board was acting up and most of the time would boot only after a CMOS reset. After flashing the BIOS everything was working again (except that Windows was crashing but it's probably not related).

In my case, no matter how many CMOS reset I did, it would only boot after several attempts (more than 10 or 20), otherwise it was only showing a black screen and rebooting randomly. After flashing the BIOS, everything was OK.
A while after, the computer was dropped while it was being moved. It was not working anymore and only boot looping before showing anything on the screen. After plugging in a POST diagnostic card, I pinpointed the problem to the RAM, it was rebooting at POST code 55 (RAM not detected) or shortly after (related to RAM). I obviously tried different sticks and none worked. I reflowed all the RAM slot solder joints, and it booted again.

Today, after a blackout, the computer did not boot (same symptoms as when I had to flash the BIOS). Last week I had a few cases where it didn't boot the first time, and before the blackout it had been running for 3 days. However it had me really confused because the POST card was showing code 32 most of the times (related to RAM) so I thought I had another RAM issue. And after trying a few different sticks it booted… Well, it was only a coincidence because after shutting it down, it didn't want to boot again. After several attemps, I was finally able to get in the BIOS. I made a dump of the current BIOS, and, strangely enough, it was getting really slow after 32% (coincidence again…). I downloaded the exact same version (1.7) and the MD5 didn't match, but that's not relevant since the downloaded file isn't a full raw dump apparently. I flashed it, and it was back in working order. I tried to dump the BIOS again and this time it went very smoothly.

I don't know why the BIOS ROM would fail, but it does. I don't know if it's a board issue or a SPI ROM issue, but now whenever I see one of those I'll remember this case and try to flash the BIOS.

TL;DR: watch out for BIOS corruptions on this board or this chip, it happens.
__________________
OpenBoardview — http://openboardview.org | IRC — #openboardview@irc.freenode.net
piernov is offline   Reply With Quote