View Single Post
Old 01-11-2019, 12:58 PM   #8
CuriousJohn
Ordained
 
Join Date: Dec 2018
City & State: Britain
My Country: Great Britain
Line Voltage: 230VAC 50HZ
I'm a: Hobbyist Tech
Posts: 21
Default Re: Bush idlcd26tv22hd 17PW15-8 issue

Quote:
Originally Posted by R_J View Post
Can you recheck R830, the schematic lists it as 0R47Ω which is 0.47Ω (close to zero ohms) also R971 is listed as 0R47, so check what is printed (or color code) on the resistors
VCC1 source for ic807 is from IC828 which is normally off but turned on with ON/OFF signal from main board

The ic828 (regulator ic) also supplies vcc2 for IC802 (PFC circuit) When you push power on, you should have vcc2 voltage on ic802 pin 8, and if the pfc circuit is working the voltage on C819 will go from 340 volts to around 400v, this circuit needs to work as circuit with (q813/814) requires 400v
You may not see any voltage on pin 7 of ic802, it will be a pulse (you would need a scope to see it)
Hi and thanks for the correction and info, was wondering if Q803 was driving or just switching the primary to ground in a brutal way i will probably realise soon how stupid that thinking is/was ha!

I confirm both R971 and R830 are indeed 0.47 and each measure around 0.6 out of circuit both in good condition so put em back in.

Vcc2 is present breifly at mains on and when power on is pressed.
.
As a bonus went to Mosfet checking school this afternoon and pulled Q803, Q813/814 and all test proper out of circuit so put em back in.

So earlier also looked at pins 1-4 of PFC IC802

Data sheet: https://www.st.com/resource/en/datasheet/l6562.pdf


when mains applied to psu, Pin 1 (inv) is around 2.12V steady but according to datasheet needs to get to 2.465v min and pin 2 seems to be intermittent showing 6v briefly dropping but only now and again at other times it sits at 0.5 ish so floating, not sure if symptomatic of bad IC802. Looking at pin 3, c805 and R803 seems to be signs of past solder flux on the pcb, R803 measures fine at 27K, C805 doesnt look to clever has burnt flux or crud on it tests in the high M Ohms, charges up tho, I may well take them off circuit and test proper whilst waiting for replacement IC802 to arrive but did re solder them just to be sure as initially found the ground side to be floating at 0.2 ish so cured that.

Cheers

Last edited by CuriousJohn; 01-11-2019 at 01:02 PM..
CuriousJohn is offline   Reply With Quote