View Single Post
Old 12-03-2017, 07:44 PM   #7
freakaftr8
Badcaps Veteran
 
freakaftr8's Avatar
 
Join Date: Oct 2012
City & State: Folsom, CA
My Country: USA
Line Voltage: 120vac 60hz
I'm a: Hobbyist Tech
Posts: 3,720
Default Re: Sony XBR75X850C no picture backlights on

Well you guys are right as soon as I plug in the far right cable to the panel I immediately get a short circuit across the four M LCC capacitors off the DC converter shown in the previous pic . What I did is I covered up with tape the 16 V drive on the right side. I immediately noticed the short was gone upon inspection of testing on the MLCC's. Then powered up suddenly I noticed all tcon voltages came back and I have a perfect left side but dead right side. So I was correct this system requires a full loop back between left to right in order to power up tcon voltages. With the data drive going to the full left and right side of the panel you can disconnect the VCC to either side and you will still get a picture. Only if all data drive output signals and feedbacks are registered being connected it will allow the T con to do a full power up regard less if one or other side 16 V VCC is connected or not

Unfortunately chock this one up to a shorted panel. What a shame. Such a nice Sony 75 inch 4k too
Attached Images
File Type: jpg 20171203_173454.jpg (433.4 KB, 56 views)
__________________
Did I leave the soldering iron on?

Last edited by freakaftr8; 12-03-2017 at 08:45 PM..
freakaftr8 is offline   Reply With Quote