Badcaps Forums

Badcaps Forums (https://www.badcaps.net/forum/index.php)
-   Troubleshooting TVs and Video Sources (https://www.badcaps.net/forum/forumdisplay.php?f=31)
-   -   Sony Bravia KDL-52S4100 No picture or Sound (https://www.badcaps.net/forum/showthread.php?t=24510)

Markw959 12-02-2012 10:21 AM

Sony Bravia KDL-52S4100 No picture or Sound
 
3 Attachment(s)
I am looking at my brothers TV he has a Sony Bravia KDL-52S4100 it has no sound or picture. When the power button is depressed the light located under the panel turns green. I removed the back and immediately checked the power supply for bad caps. There were none. I then proceeded to check all of the output voltages on the power supply. They were not perfect, but very close to nominal.

I then removed CON3 from the power supply which connects to the main board and the back light illuminated. I think there might be a problem with the main board. I have checked to just try to purchase a main board (48.71H01.31), there are none to be found. I assume this must be a huge problem for this model.

If you have any ideas on where I should start troubleshooting on the main board I would like to hear them.

I'm looking for my digital camera once I find it I will take better pictures of the boards that in question.

randtek 12-02-2012 01:00 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
The part number for the main board for this model is 185722711. I did find a few available but they are horribly expensive. (One site listed it for over $800.00 USD.) So the board replacement option is probably out.

Markw959 12-02-2012 03:01 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Yeah I have even found the set for sale used for $900.00-$1200.00 which is what they were probably going to do is buy it and sell the board for $800.00

budm 12-02-2012 07:01 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
1 Attachment(s)
Did you check the voltage and the surface mounted fuse on the T-CON board yet? This model may use error signal from T-CON board to shutdown (BL_ON) if the T-CON is dead.

bumbling808 07-13-2013 02:37 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
I know this is an old post, but I have the exact same problem. I even changed out the motherboard with no improvement. Did you ever find the problem?

capkid 07-13-2013 02:52 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by bumbling808 (Post 354740)
I know this is an old post, but I have the exact same problem. I even changed out the motherboard with no improvement. Did you ever find the problem?

When you say "motherboard", do you mean the power supply or the main board with all the inputs?

bumbling808 07-26-2013 12:08 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
1 Attachment(s)
I mean the main board. In desperation, I went ahead and ordered a replacement tcon board. Still same problem. I didn't think I needed to replace the power supply because the relay was still working during initial power up and the backlight would go on if I unplugged one of the wires that go to the main board. Should I go ahead an get a replacement power supply board now?http://www.badcaps.net/forum/attachm...1&d=1374818858

capkid 07-26-2013 12:23 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
You could have gotten a faulty replacement main board. When it comes to these Sony main boards, I prefer to have them repaired if possible rather than replacing them, or I'd buy from a highly reputable seller who offers a warranty. There are a lot of faulty main boards out there for Sonys. Where did you get the main board?

http://www.ebay.com/itm/1-857-227-11...item27d34a8e85

bumbling808 07-26-2013 12:29 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Yes on ebay, but not that listing. Here's the one I bought. Got the tcon board from the same guy. ebay listing

How can I verify which board is the problem?

capkid 07-26-2013 12:42 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
The link I provided was for a repair service. I had a KDL-46S4100 that did the exact same thing - no backlight until I unplugged the connector. My issue was a bad main board. I don't know of many Sonys that suffer from power supply issues. If your part numbers match and you're still within the time window for returns, you may want to consider returning the main board and using that repair service. It's a bit expensive, but people have had good results using that seller.

Edit: I actually bought my main board from Tristate Module, but it doesn't appear to be in stock for your TV: http://www.tristatemodule.com/p-2556...l-52s4100.aspx

fixitelectronix 02-15-2015 06:54 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Old topic. But I now have the same TV with the same issue. I've disconnected the above cable with the same results. I've used a voltmeter to test the voltage. There's 5 volt on the b-on when cable is diconnected but loses it when cable is connected. I'd like to attempt to repair the main board instead of replacing it because it's a little pricey and hard to find in stock. If others can repair then I'm sure I could as well. besides replacing the board, has anyone figured out if an IC is causing this issue. Seems like it's grounding out or something.

newtothis 02-15-2015 07:02 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Be warned mainboards are not easy to repair, Are you competent using a DMM, Scope and Soldering equipment? Do you have the available tools and materials?

If no to any of the above send it for repair

capkid 02-15-2015 08:12 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
There could be an issue with a BGA, in which case I'd be out.

fixitelectronix 02-15-2015 08:22 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by newtothis (Post 531027)
Be warned mainboards are not easy to repair, Are you competent using a DMM, Scope and Soldering equipment? Do you have the available tools and materials?

If no to any of the above send it for repair

Yes I have a DMM & soldering equipment. I can get my hands on an oscilloscope if needed. If I could find the proper schematic for the board it would help as well. I understand main boards aren't an easy task. I was just wondering what expertise we have available and if anyone has repaired this problem without replacing the board.

nomoresonys 02-15-2015 09:21 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
with a steady green light , you can try a firmware update, if you can find the firmware, in some cases it fixes the problem, maybe check sony's site for it.

fixitelectronix 02-15-2015 09:24 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Firmware update is out of the question. Unfortunately I'm unable to see an image on the screen to attempt an update plus screen went out while watching TV. Can't be a firmware issue.

nomoresonys 02-15-2015 09:28 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
thats the problem, everyones positive about everything, you dont need to see the screen with the kdl to do an update. bye now.

capkid 02-15-2015 09:34 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
I'll just leave this here, just in case: http://www.badcaps.net/forum/showpos...9&postcount=59

fixitelectronix 02-15-2015 09:57 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by nomoresonys (Post 531062)
thats the problem, everyones positive about everything, you dont need to see the screen with the kdl to do an update. bye now.

As much as I don't want to admit I was wrong, that fixed the set. You sir are a god. I can't believe that's all it was. I would give you a great big hug if I could. I applaud you :bow:

nomoresonys 02-15-2015 10:13 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
:lolsign:it happens, ASSUMPTIONS have been screwing people up since time began, including me.:noob:

topfli8979 02-18-2015 03:06 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Where did you find the firmware update? Sony has none available for this model on there site?

capkid 02-18-2015 03:28 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by topfli8979 (Post 532363)
Where did you find the firmware update? Sony has none available for this model on there site?

http://www.badcaps.net/forum/showpos...6&postcount=18

topfli8979 02-18-2015 05:08 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
:rock: That is awesome!! Thank you. It actually worked. This forum is amazing with the help a guy receives!

figureditout 06-17-2015 09:07 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
First and foremost, I'd like to thank you all very very much for having this online discussion. It's the only place that I could find the information that I was looking for. I don't normally write to forums like this, but I'm so grateful for the information and I'm hoping it will help others as well.

As described toward the end of the above thread, the firmware needed to be updated to resolve this issue. I sincerely appreciate the link and instructions given by capkid and the clue from nomoresonys that you don't need to see a picture on the screen to resolve this issue. Using those two comments, helped me tremendously. :bow:

However, I still sturggled to make this work so if you're struggling too, don't give up cause in the end, it'll save you hundreds or thousands of dollars in buying a new tv. :D

Anyways, here's what I learned after looking at capkid's link:
1) It's important to do the fat 32 format thing. I thought I could just do a simple format but figured out that's not the case. Apparently, fat 32 allows the usb to work with tvs and other special devices. Anyways, just google how to format a usb to fat 32 and you'll get the info.
2) It seems that not all usb drives work. I spent almost a full day working with one usb and thought I was done for, but in desperation, I formatted a different usb to fat 32, did the instructions from capkid and it worked!
3) I'm not sure if the way to unzip the files had to be done in any particular way but I tried it first by just right clicking on the file and extracting it. That didn't seem to work and I knew this cause the icons weren't fancy, they were pretty plain looking. Then I tried winzip which was more complicated than I wanted it to be (I was working on this for hours so I was ready to get this done!). Then I used File Extractor and it was super easy and did what I needed it to.

So I sincerely hope this additional information helps others and prevents you from being discouraged. It was worth the 7 hours that I put into figuring this thing out cause I really didn't want to or have the money to spend on a new tv. My spouse would've appreciated it though! Good luck!

Agent24 06-17-2015 10:16 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Good to hear!

capkid 06-18-2015 02:56 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Nice. Glad to be of help.

nkhilji 08-18-2015 09:22 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
This story is just amazing. So I picked this kdl52s4100 last Sunday for $21 at an estate sale. The sign on it said that it did not work. The green light would come on and that was it, no picture, no sound. I thought 'what the hell, I will check it out and search the internet for some ideas, if it does not work, I will junk it and only be out $21 but at least I had my fun'. So Monday (yesterday) I do a google search and land on this forum and read the advice for updating firmware. I honestly did not believe until the other guy who tried it reported that it worked. So today I thought let me try and I have many extra flash drives. So I followed the links and downloaded the software and followed the instructions of putting the usb in the tv and waiting around till the timer light blinked ember and the power light blinked green. Shut the tv off and then on. Voila! the picture came on!

I was so amazed that I registered on this forum just to thank you gentlemen, the one who gave the advice, and the one who took it. I am an economist and I make assumptions all the time about peoples behavior, about markets, about governments, etc. Cheers and I wish I could buy you huys a drink.

capkid 08-18-2015 09:45 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
$21...very nice. Glad you were able to get it working.

Rickig 10-05-2015 11:29 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Capkid any chance you have the update for a kdl-40w5810 I am experiencing the same symptoms with my set.

capkid 10-05-2015 11:38 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by Rickig (Post 595625)
Capkid any chance you have the update for a kdl-40w5810 I am experiencing the same symptoms with my set.

This may work: https://www.sony.co.uk/support/en/co...sa/KDL-40W5810

Rickig 10-05-2015 02:20 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
No
Already tried that. Doesn't even try to update with that file. I assume it needs to be told to look for it...

capkid 10-05-2015 02:32 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by Rickig (Post 595686)
No
Already tried that. Doesn't even try to update with that file. I assume it needs to be told to look for it...

The TV should find the software if you've installed it at the USB drive's root. Did you format the drive? FAT32 for S4100's - not sure for your set, but I assume it's the same.

vinceroger69 10-05-2015 02:40 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by Rickig (Post 595686)
No
Already tried that. Doesn't even try to update with that file. I assume it needs to be told to look for it...

Not sure if you saw this
http://www.mediafire.com/view/pijwf7...structions.pdf

jazzco 12-24-2015 11:56 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
I cant download the instructions can someone post them please I have the same problem

jazzco 12-24-2015 01:53 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by jazzco (Post 617992)
I cant download the instructions can someone post them please I have the same problem

I got the instructions but it didn't up date. what can I be doing wrong? turned the TV off put the usb in turned it on the power light comes on but not the timer light (I waited longer than 20sec) like its not seeing the usb firmware

budm 12-24-2015 03:07 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Did you format the stick with FAT32?
I also kept the firmware and the instruction here:
http://www.badcaps.net/forum/showpos...&postcount=145

jazzco 12-25-2015 06:57 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
I did all that but same thing over and over again

budm 12-25-2015 11:03 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
You see post 24 about the memory stick?

jazzco 12-27-2015 12:44 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
I tryed 2 different drives format fat32 I must suck this seems so easy

jazzco 12-31-2015 02:54 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Its not see that I have a drive in any info on that?


All times are GMT -6. The time now is 03:19 AM.

Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.