Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting TVs and Video Sources
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 09-30-2010, 01:55 PM   #61
PlainBill
Badcaps Veteran
 
PlainBill's Avatar
 
Join Date: Feb 2009
City & State: Phoenix, AZ
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Hobbyist
Posts: 7,013
Default Re: Sony Bravia no picture but backlight on

Quote:
Originally Posted by BCR View Post
The cable is good, it is a 1 meter cable that I use everyday on the PS3 straight to other TV, but I did try a second cable to be sure. As well, went around every board on TV and checked connections, all look good (some grease, but that is standard).
It doesn't have to be a connector. Lead free solder is notorious for prodicing joints that look good, but are intermittent. When you plugged in the cable you put pressure on the circuit board, causing it to flex slightly. That caused two points to rub across one another and make contact - at least for a while.

The explanation is easy. Finding the bad solder joint is the hard part. The good news is the harder it is to find, the greater your sense of accomplishment when you succeed.

PlainBill
__________________
For a number of reasons, both health and personal, I will no longer be active on this board. Any PMs asking for assistance will be ignored.

Never be afraid to try something new. Remember, amateurs built the ark. Professionals built the Titanic.
PlainBill is offline   Reply With Quote
Old 10-04-2010, 12:03 PM   #62
truep
Badcaps Veteran
 
Join Date: Aug 2010
City & State: Flower mound, TX
My Country: USA
Line Voltage: 120VAC 60 HZ
I'm a: Knowledge Seeker
Posts: 326
Default Re: Sony Bravia no picture but backlight on

I replaced a sony panel with one from a toshiba once. Just the LCD portion as the sony was cracked. Check the number on the circuit board at the top of the lcd panel itself not the tcon. Mine had the same part number but a different rev number but it worked! I'm betting it's the main board.
truep is offline   Reply With Quote
Old 10-11-2010, 09:08 AM   #63
BCR
Member
 
Join Date: Sep 2010
City & State: South Florida
Posts: 14
Default Re: Sony Bravia no picture but backlight on

Quote:
Originally Posted by PlainBill View Post
The explanation is easy. Finding the bad solder joint is the hard part. The good news is the harder it is to find, the greater your sense of accomplishment when you succeed.

PlainBill
Thanks for the info, I may just give this to a Pro (if it can be done for under 500.00 with 30 day warranty)
Sadly, I had just missed a fellow on eBay with same TV that had a cracked screen, he was selling all the boards at 0.99 starting price. I should have bought all of them for well under 500.00 something like 200.00 with shipping would have got them all.
BCR is offline   Reply With Quote
Old 10-11-2010, 09:09 AM   #64
BCR
Member
 
Join Date: Sep 2010
City & State: South Florida
Posts: 14
Default Re: Sony Bravia no picture but backlight on

Should I just start a new thread with my pics??

EDIT:: Or just post pics here?
BCR is offline   Reply With Quote
Old 10-11-2010, 10:15 AM   #65
PlainBill
Badcaps Veteran
 
PlainBill's Avatar
 
Join Date: Feb 2009
City & State: Phoenix, AZ
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Hobbyist
Posts: 7,013
Default Re: Sony Bravia no picture but backlight on

Quote:
Originally Posted by BCR View Post
Should I just start a new thread with my pics??

EDIT:: Or just post pics here?
Just add your pictures to this thread.

PlainBill
PlainBill is offline   Reply With Quote
Old 10-11-2010, 10:27 AM   #66
BCR
Member
 
Join Date: Sep 2010
City & State: South Florida
Posts: 14
Default Re: Sony Bravia no picture but backlight on

OK, not sure on the rules of pics here. but I sized them to 800x600 and have many....
Here are some of the pics, any close ups needed just say so. Thanks...
Attached Images
File Type: jpg PICT0001_converted_(800x600).jpg (58.8 KB, 54 views)
File Type: jpg PICT0002_converted_(800x600).jpg (82.9 KB, 57 views)
File Type: jpg PICT0003 (2)_converted_(800x600).jpg (80.7 KB, 48 views)
File Type: jpg PICT0004 (2)_converted_(800x600).jpg (82.5 KB, 43 views)
File Type: jpg PICT0004_converted_(800x600).jpg (69.7 KB, 42 views)
File Type: jpg PICT0006 (2)_converted_(800x600).jpg (62.0 KB, 38 views)
File Type: jpg PICT0007 (2)_converted_(800x600).jpg (65.8 KB, 39 views)
File Type: jpg PICT0007_converted_(800x600).jpg (91.2 KB, 41 views)
File Type: jpg PICT0008 (2)_converted_(800x600).jpg (58.6 KB, 36 views)
File Type: jpg PICT0017_converted_(800x600).jpg (101.4 KB, 46 views)
BCR is offline   Reply With Quote
Old 10-19-2010, 06:44 AM   #67
BCR
Member
 
Join Date: Sep 2010
City & State: South Florida
Posts: 14
Default Re: Sony Bravia no picture but backlight on

OK here is the TV-Cont. board, which one is the fuse that I should check????
Also what is the best way to get those top cables off? The bottom one you just squeeze on the sides, but not the top ones...
Attached Images
File Type: jpg PICT0001_converted_(800x600).jpg (60.2 KB, 66 views)
File Type: jpg PICT0003_converted_(800x600).jpg (58.9 KB, 49 views)
File Type: jpg PICT0004_converted_(800x600).jpg (66.8 KB, 44 views)
File Type: jpg PICT0005_converted_(800x600).jpg (65.2 KB, 44 views)
BCR is offline   Reply With Quote
Old 10-19-2010, 06:52 AM   #68
Wrog
Badcaps Veteran
 
Join Date: Oct 2009
City & State: Florida
Posts: 450
Default Re: Sony Bravia no picture but backlight on

Rules of the pics. Ideally you would get them as close to 2000x2000 as possible (maximum dimension on one side) so that we can see the details.

The top connector is fragile -- the black part swings up to a 90 degree angle and the cable slides out.
Wrog is offline   Reply With Quote
Old 10-19-2010, 07:01 AM   #69
BCR
Member
 
Join Date: Sep 2010
City & State: South Florida
Posts: 14
Default Re: Sony Bravia no picture but backlight on

Cool thanks, and thanks..
Looking at average the part goes for around 120.00 so not to bad if it is the correct part to fix.
EDIT Where abouts in Florida?
BCR is offline   Reply With Quote
Old 11-09-2010, 12:36 AM   #70
xmikee
New Member
 
Join Date: Nov 2010
Posts: 2
Default Re: Sony Bravia no picture but backlight on

Quote:
Originally Posted by Wizard View Post
unplugged from power for safety sakes!

Yes all these medium to big ones brown-purplish look blocks on T-CON. Rest of other boards don't worry about those yet.

Cheers, Wizard
Hi could you help, i recently attempted to do a TAB DOND FIX ON MY kdL52X350, All went well until one of the metal clips touched the circuit board that holds the metal frame around LCD panel, Now the backlight does not work and also no picture, The sound is ok. What do you think would of been damged. The TAB Panel, Tcon Board, LCD board that connects to Tcon, Any advice would be great. thank you.
xmikee is offline   Reply With Quote
Old 11-09-2010, 05:26 PM   #71
xmikee
New Member
 
Join Date: Nov 2010
Posts: 2
Default Re: Sony Bravia no picture but backlight on

Quote:
Originally Posted by PlainBill View Post
Just add your pictures to this thread.

PlainBill
hi could you help with problem below, Update sound works, no backlight, no video. thx Ps. my tv is a KDL 52X3500 AKA KDL 52XBR
xmikee is offline   Reply With Quote
Old 11-09-2010, 06:02 PM   #72
PlainBill
Badcaps Veteran
 
PlainBill's Avatar
 
Join Date: Feb 2009
City & State: Phoenix, AZ
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Hobbyist
Posts: 7,013
Default Re: Sony Bravia no picture but backlight on

Quote:
Originally Posted by xmikee View Post
hi could you help with problem below, Update sound works, no backlight, no video. thx Ps. my tv is a KDL 52X3500 AKA KDL 52XBR
I suggest you ask the guy who gave you the advice for help. I'm not experienced with panels at that depth. Since both the backlight and the panel do not work, you probably blew the main board.

PlainBill
PlainBill is offline   Reply With Quote
Old 12-26-2010, 08:07 PM   #73
gt4rusty
New Member
 
Join Date: Nov 2010
City & State: Central Ohio
Posts: 2
Default Re: Sony Bravia no picture but backlight on

I have a Sony KDL-52W4100 a little less than 2 years old. I turned it on and after 30 seconds heard a pop and the picture went out (back light still on) and the red LED flashed 14 times( Panel Error I believe). After reading through this and numerous other threads on the issue decided to look at the fuse on the TCON board. Before I even checked the fuse I found what appears to be a burnt capacitor (pictures attached). I have ordered a new board from Sony and have a couple of questions. Do you think this is an issue with the board, or should I check another component before putting the new board in only to have it happen again? I have seen that heat is a real issue with the board, is it OK to put heat sink grease on the pads to ensure better transfer or are they good enough as is?
Thanks for the information, I wouldn't have gotten this far with out it.
Attached Images
File Type: png tcon 2.png (957.4 KB, 64 views)
File Type: png tcon 1.png (1.47 MB, 63 views)
gt4rusty is offline   Reply With Quote
Old 12-27-2010, 08:43 PM   #74
gt4rusty
New Member
 
Join Date: Nov 2010
City & State: Central Ohio
Posts: 2
Default Re: Sony Bravia no picture but backlight on

I apologize I believe I am looking at a bad SMD resistor, not a bad capacitor. I mistakenly thought because of the "C" designation on the board that it may have been a cap.
__________________
Rusty
gt4rusty is offline   Reply With Quote
Old 12-31-2010, 03:00 PM   #75
kjcdal
New Member
 
Join Date: May 2010
Posts: 2
Default Re: Sony Bravia no picture but backlight on

hi hope someone can help i have a sony bravia kdl 40v2500, it swicthes on fine with steady green light and sound is perfect but no picture can hear channel change and volume works fine, you can also c the backlight on, i have changed the t con board and when i first done that and turned it on two white lines came up, turned the tv on and off again and the lines are now gone but still no picture the same as before so now am stuck dont know where to go have checked all wires and cracks and everything seemd fine so i hope someone can help thankyou.
kjcdal is offline   Reply With Quote
Old 11-04-2011, 01:07 AM   #76
static4real
New Member
 
Join Date: Nov 2011
Posts: 1
Smile Re: Sony Bravia no picture but backlight on

Quote:
Originally Posted by Wizard View Post
T-CON is staring right at you. Right in middle at top hiding behind the vented cover with 4 little screws.

Do you have multi-meter? Take T-CON cover off and find a small SMD fuse and measure this first, tend to be very near the LVDS connector. You want very low ohms. If high ohms, bridge this old fuse with 2A picofuse secured with bit of soldering job on both ends. Take very clear picture of the exposed T-CON board.

Make sure T-CON have thermal pad atop the big square chip and any smaller ones if are there.

Cheers, Wizard
i have a bravia kdl 46w3000 with same issue. backlights are perfect, i hear sound from all ports but no picture at all. screen lights up and changes as i flip channels but there is no letters or words or numbering just a blank lit screen no matter what i do. i reseated all cables, tightened down screws, checked for bad caps and everything seems fine. what is the problem im having? sorry im not sure how to do this, its my first time ever using a forum in my life. hope i did this right
static4real is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:42 PM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?