Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting TVs and Video Sources
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 04-17-2013, 05:30 PM   #1
notsogentle
New Member
 
Join Date: Jan 2013
City & State: midland ontario
My Country: canada
I'm a: Knowledge Seeker
Posts: 12
Default Rca l32hd31yx16

Hi folks! I got this today, and it powers on, but no proper picture. I have no inputs attached. Starts out blue but very quickly fades across the screen black then blue again. bad panel? or is it simple like t-con or mainboard problem?

hopefully photos post in order, it happens pretty quick.
Attached Images
File Type: jpg IMAG0040.jpg (717.1 KB, 6 views)
File Type: jpg IMAG0041.jpg (579.7 KB, 4 views)
File Type: jpg IMAG0042.jpg (539.0 KB, 2 views)
File Type: jpg IMAG0043.jpg (283.8 KB, 4 views)
notsogentle is offline   Reply With Quote
Old 03-07-2014, 06:10 AM   #2
aasnowskate
Member
 
Join Date: Jan 2013
City & State: pennsylvania
My Country: usa
I'm a: Knowledge Seeker
Posts: 94
Default Re: Rca l32hd31yx16

HI I have the same Model TV with the same problem. Did you ever get anywhere with this?
aasnowskate is offline   Reply With Quote
Old 03-07-2014, 09:36 AM   #3
Caleb
Smokin IC's
 
Caleb's Avatar
 
Join Date: Feb 2013
City & State: Eugene, Oregon
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Hobbyist Tech
Posts: 412
Default Re: Rca l32hd31yx16

I would start testing with the tcon, followed by the main board. Both are available on Shop Jimmy depends on how much money you want to throw at it. attached is the only schematic I could find for it
Attached Files
File Type: pdf rca_l32hd31_sch.pdf (3.86 MB, 7 views)

Last edited by Caleb; 03-07-2014 at 09:39 AM..
Caleb is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:14 PM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?