Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting TVs and Video Sources
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 09-23-2012, 11:13 AM   #1
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default SANYO DP37647 Sound no Picture

It powers on just fine with sound, no pic or back lights.

Power board readings:
Cn2 goes to main
PS_on 4.9 v
5vsb 5.0 5.0 v
12v 12.0 12.1 v
24v 24.1 24.1 v
CN4 goes to inverter
24.0v
24.1v
24.1v
24.0v
MAINBOARD from Power board
K8B
white 4.9v
12.0v
12.0v
24.1v
24.0v

K6R goes to inverter
white 3.3v
3.3v
0.3v
4.3v
Attached Images
File Type: jpg WP_001311.jpg (388.1 KB, 27 views)
File Type: jpg WP_001310.jpg (379.3 KB, 22 views)
File Type: jpg WP_001308.jpg (540.3 KB, 21 views)
Attached Files
File Type: pdf sanyo_dp32647_chassis_p32647-03m_sm.pdf (5.82 MB, 38 views)
lilmonk3 is offline   Reply With Quote
Old 09-23-2012, 11:15 AM   #2
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

No backlight or no image on lit screen?
Check inverter fuse.
__________________
Please do not PM me for help and support. Questions belong on the public forum.

68 LED/LCD TVs, 5 monitors, 26 plasma TVs, and 2 AVR 6.1 amplifiers saved from the dump!
Totally free service manuals database: http://www.toms-service-manuals.com/ (Contact me for requests or contributions.)

I have successfully fixed (from best --> worst build quality):
1 Pioneer KURO 9G, 10 Panasonic LCD/Plasma, 1 Sony LCD, 1 NEC Plasma, 2 Yamaha HTS, 4 Sharp LCDs, 5 Toshiba LCDs, 7 Philips Plasma/LCD, 1 Hitachi Plasma, 10 LG LCD/Plasma, 15 Samsung LED/LCD/Plasma, 1 Thomson Plasma, 1 Atec LCD, 1 Hanspree LCD, 1 Xerox LCD, 1 Harwa LCD, 2 Proview LCD, 2 Hyundai LCD, 1 "Onn" LCD, 1 Grundig LCD, 1 Dell LCD, 1 iiyama LCD, 1 Acer LED, 1 Logik LCD, 1 Baird (China) LCD, 6 Bush LCDs, 19 Vestel LCDs
tom66 is offline   Reply With Quote
Old 09-23-2012, 11:34 AM   #3
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default Re: SANYO DP37647 Sound no Picture

Fuse and transformers all in spec .. I should have said I already tried a replacement inverter..

Last edited by lilmonk3; 09-23-2012 at 11:36 AM..
lilmonk3 is offline   Reply With Quote
Old 09-23-2012, 11:35 AM   #4
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

Inverter VIN measures 4.3V? That is too low but you do have 24V on your power board. Check if there are fuses on the power board - maybe one there.
tom66 is offline   Reply With Quote
Old 09-23-2012, 11:38 AM   #5
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default Re: SANYO DP37647 Sound no Picture

Yes I have 24v on power board .. The 4.3 is coming from the main to the inverter
lilmonk3 is offline   Reply With Quote
Old 09-23-2012, 11:40 AM   #6
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

Can you post a clear shot of the inverter? It doesn't look like the 24V is getting to the inverter - I'm suspecting a fuse on the PSU somewhere (and fuses can be deceptive, looking like anything...) This TV probably uses the 24V for the audio circuit as well, many do.
tom66 is offline   Reply With Quote
Old 09-23-2012, 11:52 AM   #7
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default Re: SANYO DP37647 Sound no Picture

I was just looking over the Power board and found this.. Would this ferrite bead cause a problem
Attached Images
File Type: jpg WP_001312.jpg (349.1 KB, 39 views)
lilmonk3 is offline   Reply With Quote
Old 09-23-2012, 11:57 AM   #8
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

I don't think so - it's just a bit of ferrous material wrapper around a wire. It's to reduce the interference the TV can kick out with regards to radios etc.
tom66 is offline   Reply With Quote
Old 09-23-2012, 12:10 PM   #9
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default Re: SANYO DP37647 Sound no Picture

Its a long inverter.. Here are a few pics
Attached Images
File Type: jpg WP_001315.jpg (536.9 KB, 21 views)
File Type: jpg WP_001316.jpg (627.2 KB, 13 views)
File Type: jpg WP_001317.jpg (565.1 KB, 7 views)
File Type: jpg WP_001318.jpg (567.2 KB, 5 views)
lilmonk3 is offline   Reply With Quote
Old 09-23-2012, 12:17 PM   #10
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default Re: SANYO DP37647 Sound no Picture

One thing that made me scratch my head is... On the power board there is a cable 24v connection CN5 that is empty and there is also and empty connection on the inverter.. Is there SUPPOSE to be a cable going between the 2....
Attached Images
File Type: jpg WP_001321.jpg (523.1 KB, 19 views)
lilmonk3 is offline   Reply With Quote
Old 09-23-2012, 12:19 PM   #11
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

OK, test the voltage as indicated in the image. Red probe on the red highlighted pin, black on the black highlighted pin.

You can test the voltage on any of the main caps on the inverter.
Attached Images
File Type: jpg testsanyo.jpg (437.7 KB, 29 views)
tom66 is offline   Reply With Quote
Old 09-23-2012, 12:20 PM   #12
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

Hmm I wonder. Perhaps the owner tried to fix their TV?
tom66 is offline   Reply With Quote
Old 09-23-2012, 12:29 PM   #13
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default Re: SANYO DP37647 Sound no Picture

Thats what I am wondering... The set didnt SEEM to have been opened but ya never know
lilmonk3 is offline   Reply With Quote
Old 09-23-2012, 12:41 PM   #14
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

Do the check I mentioned - if it's zero volts or near enough zero, you can always solder individual wires between the PSU and inverter or crimp your own cable.
tom66 is offline   Reply With Quote
Old 09-23-2012, 12:45 PM   #15
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default Re: SANYO DP37647 Sound no Picture

24v on all caps on inverter
lilmonk3 is offline   Reply With Quote
Old 09-23-2012, 12:49 PM   #16
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

So I think it's OK. That plug on the PSU is probably for a slave inverter, and on the other inverter is probably for a different PSU, or for use as a slave inverter in some way. Check all the transformers on the inverter next as you have Darfon ones and they often fail.
tom66 is offline   Reply With Quote
Old 09-23-2012, 01:16 PM   #17
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default Re: SANYO DP37647 Sound no Picture

Transformer all are good.. One of the first things I checked
lilmonk3 is offline   Reply With Quote
Old 09-23-2012, 01:22 PM   #18
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

Check the primaries of the transformers too. I've never seen one fail, but wouldn't rule it out. You are expecting close to 0 ohms.
tom66 is offline   Reply With Quote
Old 09-23-2012, 01:23 PM   #19
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 26,814
Default Re: SANYO DP37647 Sound no Picture

Oh, and did you check this fuse too?
Attached Images
File Type: jpg checkthistoo.jpg (504.2 KB, 30 views)
tom66 is offline   Reply With Quote
Old 09-23-2012, 01:29 PM   #20
lilmonk3
Badcaps Veteran
 
Join Date: Apr 2012
City & State: Kansas
My Country: USA
I'm a: Knowledge Seeker
Posts: 238
Default Re: SANYO DP37647 Sound no Picture

Secondary all 0.3, primary 2.15 ,all white fuses 1.0
lilmonk3 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:07 AM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?