Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting TVs and Video Sources
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 05-19-2012, 01:50 PM   #1
wohdin
New Member
 
Join Date: May 2012
City & State: Manchester, KY
My Country: USA
I'm a: Knowledge Seeker
Posts: 2
Default Polaroid TLX-03210B not responding.... at all

This is NOT the "smoking/bulging cap" issue, or at least not the one that everyone else seems to have. Recently a TV stopped responding ENTIRELY to ANY sort of input after having a VGA cable plugged to my PC from the graphics card (I don't really think this was the cause of the issue, though - how would that even work?). I plugged it in, and for a moment it worked fine - it displayed the image from my PC, albeit in the wrong resolution, and it didn't seem to show any problems. But I turned the TV off for a moment while I went to the bathroom, and when I went back, I tried to turn it back on, but... nothing. The LED was red, and it did nothing. I tried the power button on both the TV's panel and the stock remote that came with it, and nothing. I tried power cycling it to restore it to factory settings, and nothing. I've even taken it apart to check for problems, and I checked and reconnected the connectors of the control panel and everything else, and nothing had any noticeable problems. I don't really know what a "bulging capacitor" would look like, but I didn't see anything that looked particularly abnormal.

All it does is sit there, with the LED on red, and does not respond to anything. At all.

Any suggestions for what the problem might be, or what I should do to get to the bottom of the problem? I'm not exactly an experienced electrician, but I've "serviced" several smaller devices (video game consoles, VCR/DVD players, PCs) in the past, and never had a problem as weird as this before.

This TV is about 2 years old and I'm pretty sure it's well past its warranty.

[e] pics: http://www.mediafire.com/?llzu2o25nkqc5

Last edited by wohdin; 05-19-2012 at 03:19 PM.. Reason: pics
wohdin is offline   Reply With Quote
Old 05-19-2012, 02:19 PM   #2
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 25,247
Default Re: Polaroid TLX-03210B not responding.... at all

Can you take some pictures of the boards in your TV? These Polaroids (and in general the Proview chassis) has a problem with the main board cage getting mis-seated from the main connector.
__________________
Don't PM me for help and support. Questions belong on the public forum.

65 LED/LCD TVs, 5 monitors, 24 plasma TVs, and 2 AVR 6.1 amplifiers saved from the dump!
Totally free service manuals database: http://www.toms-service-manuals.com/ (Contact me for requests or contributions.)

I have successfully fixed (from best --> worst build quality):
1 Pioneer KURO 9G, 8 Panasonic LCD/Plasma, 1 Sony LCD, 1 NEC Plasma, 2 Yamaha HTS, 4 Sharp LCDs, 5 Toshiba LCDs, 7 Philips Plasma/LCD, 1 Hitachi Plasma, 9 LG LCD/Plasma, 14 Samsung LED/LCD/Plasma, 1 Thomson Plasma, 1 Atec LCD, 1 Hanspree LCD, 1 Xerox LCD, 1 Harwa LCD, 2 Proview LCD, 2 Hyundai LCD, 1 "Onn" LCD, 1 Grundig LCD, 1 Dell LCD, 1 iiyama LCD, 1 Acer LED, 1 Logik LCD, 6 Bush LCDs, 19 Vestel LCDs
tom66 is offline   Reply With Quote
Old 05-19-2012, 02:21 PM   #3
crtfool
Member
 
Join Date: Jun 2010
City & State: New York
My Country: USA
I'm a: Knowledge Seeker
Posts: 77
Default Re: Polaroid TLX-03210B not responding.... at all

This is a very common Polaroid defect - aka "the red light of death". The problem is the control board - nobody has been able to figure out what goes wrong with it. Your best solution is to get a working board from a set with a cracked screen. Several people have posted horror stories from boards acquired on eBay. I also had difficulty with 1 board that I got on eBay, but the second board worked perfectly. This is the part number: 200-107-GT321XA-BH
crtfool is offline   Reply With Quote
Old 05-19-2012, 03:00 PM   #4
wohdin
New Member
 
Join Date: May 2012
City & State: Manchester, KY
My Country: USA
I'm a: Knowledge Seeker
Posts: 2
Default Re: Polaroid TLX-03210B not responding.... at all

http://imgur.com/a/yVeGr#0
Here are some pics of the boards, but imgur seems to have shrunk them. I'll mediafire them in a bit.

http://www.mediafire.com/?llzu2o25nkqc5

Last edited by wohdin; 05-19-2012 at 03:09 PM.. Reason: links
wohdin is offline   Reply With Quote
Old 05-19-2012, 09:23 PM   #5
colormebad
colormebad
 
Join Date: Dec 2010
City & State: Corinth Ms
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Forum Junkie
Posts: 80
Default Re: Polaroid TLX-03210B not responding.... at all

I have all boards for a Polaroid, will have to check to see if its the same model or not..
colormebad is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:49 AM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?