Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting TVs and Video Sources
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 05-06-2011, 12:35 PM   #1
Houston1381
New Member
 
Join Date: May 2011
Posts: 3
Default sony kdl-46S4100 dark, no sound, inverter?

I have a sony kdl-46S4100 that one day went dark,
no sound,
powers on by the remote,
has a click at power on,
power light glows steady,
no backlight that I can see
no heat detected anywhere
remote fails to do anything after power on
no sound, no smell

Ive been swapping parts from ebay trying one different board at a time

power supply board - no change
main board - no change

I have a salvaged tcon board and inverter board that i have not tried yet.

Anyone have a beginners troubleshoot algorithm that I can do with a multimeter? Sorry in advance, I'm trying to learn this as I go.
Houston1381 is offline   Reply With Quote
Old 05-06-2011, 02:16 PM   #2
Village Electronics
OldPro
 
Village Electronics's Avatar
 
Join Date: Apr 2011
Posts: 117
Default Re: sony kdl-46S4100 dark, no sound, inverter?

Quote:
Originally Posted by Houston1381 View Post
I have a sony kdl-46S4100 that one day went dark,
no sound,
powers on by the remote,
has a click at power on,
power light glows steady,
no backlight that I can see
no heat detected anywhere
remote fails to do anything after power on
no sound, no smell

Ive been swapping parts from ebay trying one different board at a time

power supply board - no change
main board - no change

I have a salvaged tcon board and inverter board that i have not tried yet.

Anyone have a beginners troubleshoot algorithm that I can do with a multimeter? Sorry in advance, I'm trying to learn this as I go.
Blink Code?
Village Electronics is offline   Reply With Quote
Old 05-06-2011, 02:51 PM   #3
Houston1381
New Member
 
Join Date: May 2011
Posts: 3
Default Re: sony kdl-46S4100 dark, no sound, inverter?

No blinks - this model does not do that
Houston1381 is offline   Reply With Quote
Old 05-06-2011, 06:29 PM   #4
Village Electronics
OldPro
 
Village Electronics's Avatar
 
Join Date: Apr 2011
Posts: 117
Default Re: sony kdl-46S4100 dark, no sound, inverter?

Quote:
Originally Posted by Houston1381 View Post
No blinks - this model does not do that
You are correct. It does not do that.
Village Electronics is offline   Reply With Quote
Old 05-06-2011, 09:08 PM   #5
cadiman
Badcaps Veteran
 
Join Date: Mar 2010
City & State: chesterland Ohio
Posts: 398
Default Re: sony kdl-46S4100 dark, no sound, inverter?

Faulty panel or t-con.

Could be either with this panel.

check for 12vdc or so at t-con board fuse (very small near plug).

Grey panel (some backlight trying to get through) could mean no power to t-con.

Run through inputs with dvd plyer hooked up and listen for audio.

Just a few ideas for you.
cadiman is offline   Reply With Quote
Old 05-08-2011, 08:21 AM   #6
Houston1381
New Member
 
Join Date: May 2011
Posts: 3
Default Re: sony kdl-46S4100 dark, no sound, inverter?

Solved!

Thanks to cadiman for the tip - I swapped out the salvaged t-con board and it started working. I am still looking for the fuse in case this one fails too.

My process was:
take the back off and look for any bad caps anywhere on the PS or main board - dead end
research web for known issues -couldnt find any exactly like mine - most had sound or some other first symptom
swap out power supply with a ps from ebay - dead end
found another guy on ebay selling the guts of a tv like mine with cracked screen
swap out main board - dead end
put all oriiginal parts back in between attempts
buy a correct screwdriver that loosens really small phillips screws without stripping
remove tcon board
jerked out the ribbon cable from the board and tv - then found there was a little tab that popped up that pinched down the cable - luckily I didnt destroy the ribbon
test
shout up the stairs that I fixed my tv

Thanks for the tip and the forum
Houston1381 is offline   Reply With Quote
Old 05-08-2011, 08:14 PM   #7
cadiman
Badcaps Veteran
 
Join Date: Mar 2010
City & State: chesterland Ohio
Posts: 398
Default Re: sony kdl-46S4100 dark, no sound, inverter?

You would have better luck using a microscope than any type of eyeglasses to find the fuse on the t-con. should be next to the input plug. The board will be marked F with a number after it like (F101). F for fuse. R for resister , D for diode etc.

If the fuse is blown on the t-con do not jump it with solder.

Glad we could help you!
cadiman is offline   Reply With Quote
Old 11-10-2011, 05:48 PM   #8
chums12
New Member
 
Join Date: Nov 2011
Posts: 1
Default Re: sony kdl-46S4100 dark, no sound, inverter?

I also have a sony kdl 46s4100 and have the same exact problems that Houston1381 had. So i tried swapping the t-con board with a salvaged one but nothing happen. I was wondering if someone can please help me.
chums12 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:49 PM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?