Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting TVs and Video Sources
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 12-05-2010, 12:18 PM   #1
afitch87
New Member
 
Join Date: Dec 2010
Posts: 1
Default KLD-46S4100 No Picture/No Sound

I have a sony bravia with no picture and no sound the green power light stays on steadily and there is no error signal from the standby light. When I unplug the CN2502 cord that controls the backlight, the backlight comes on and the screen cycles through screens of rbg solid color screens. I think that the A board is the problem, but want to be sure before I order a new one.
afitch87 is offline   Reply With Quote
Old 08-21-2011, 08:27 PM   #2
serveles
New Member
 
Join Date: Aug 2011
Posts: 6
Default Re: KLD-46S4100 No Picture/No Sound

I have the same problem, I saw the training manual and say that if have 12v and 3.3 from the power supply the problem is in the A-Board, but I have 11.6 in the 12v and I need now if the problem is in the A-board or in the power supply.
serveles is offline   Reply With Quote
Old 08-21-2011, 08:58 PM   #3
gorr35
Senior Member
 
Join Date: Nov 2010
City & State: Vancouver,WA
Posts: 103
Default Re: KLD-46S4100 No Picture/No Sound

Pictures with the back cover removed would be nice!
gorr35 is offline   Reply With Quote
Old 08-22-2011, 10:14 AM   #4
rmoody
Learning Member
 
Join Date: Jul 2011
City & State: West Tennessee
Posts: 214
Default Re: KLD-46S4100 No Picture/No Sound

I had a similar model doing the same thing and it was the F1 fuse on the Tcon board. Check it first. Tcon is located at the top center of the tv. Fuse should be located near the bottom center of the board.
rmoody is offline   Reply With Quote
Old 08-22-2011, 01:22 PM   #5
serveles
New Member
 
Join Date: Aug 2011
Posts: 6
Default Re: KLD-46S4100 No Picture/No Sound

Thanks for your reply, rmoody, I cheked the fuse and is good, have 11.6v.
I thing is the A -Board, but I want to be sure before to order.
serveles is offline   Reply With Quote
Old 08-22-2011, 05:05 PM   #6
rmoody
Learning Member
 
Join Date: Jul 2011
City & State: West Tennessee
Posts: 214
Default Re: KLD-46S4100 No Picture/No Sound

Quote:
Originally Posted by serveles View Post
Thanks for your reply, rmoody, I cheked the fuse and is good, have 11.6v.
I thing is the A -Board, but I want to be sure before to order.
On both ends of the fuse? did you check it for continuity? If your planning on throwing boards at it, I would try the tcon first, since it's likely the cheapest. Check and see if there's another fuse. i'm thinking mine had 2 or 3
rmoody is offline   Reply With Quote
Old 08-22-2011, 05:11 PM   #7
shougang_wang
New Member
 
Join Date: Aug 2011
Posts: 4
Unhappy Re: KLD-46S4100 No Picture/No Sound

I had the exact same brand and model number and the exact same problem.

Have you fix your problem?

I would like to know how you fix it and probably I can do the same to mine.

To restate the problem.


Sony LCD TV KLD-46S4100 46in. HDTV

About a year after warranty, one day it suddenly can not display images.


The remote control can only turn the TV on and off.
The on and off green LED light and the click sound indicate there is something happen.

All other buttons on remote control do not work. All control buttons on top of the TV do not work.

TV has no sound no picture, nothing other than the green indication light at the bottom.


When I open the back, I did not notice any strange smell or any electronic component burn, leaking, bulky problem.


Sony said it is out of warranty, local repair store said $75 for problem diagnosis + other fixing fees and labor.
It can easily goes to several hundreds which does not worth it.

If a guru here has some opinion, that will be really really of great help.
shougang_wang is offline   Reply With Quote
Old 08-22-2011, 05:15 PM   #8
rmoody
Learning Member
 
Join Date: Jul 2011
City & State: West Tennessee
Posts: 214
Default Re: KLD-46S4100 No Picture/No Sound

Quote:
Originally Posted by afitch87 View Post
I have a sony bravia with no picture and no sound the green power light stays on steadily and there is no error signal from the standby light. When I unplug the CN2502 cord that controls the backlight, the backlight comes on and the screen cycles through screens of rbg solid color screens. I think that the A board is the problem, but want to be sure before I order a new one.
If you'll get us some quality pictures posted through the manage attachments, we could probably give you some quality advice. we have no idea what the CN2502 cord is
rmoody is offline   Reply With Quote
Old 08-23-2011, 12:45 AM   #9
serveles
New Member
 
Join Date: Aug 2011
Posts: 6
Default Re: KLD-46S4100 No Picture/No Sound

Ok the CN2502 is the backlight conector, and disconected, turn on the lamps and start a test (green light, red, etc..). Then the lamps and inverter works good.
serveles is offline   Reply With Quote
Old 08-23-2011, 12:50 AM   #10
serveles
New Member
 
Join Date: Aug 2011
Posts: 6
Default Re: KLD-46S4100 No Picture/No Sound

The t-con board have only one fuse in the 12v, and the mine is good
serveles is offline   Reply With Quote
Old 08-23-2011, 07:09 AM   #11
Village Electronics
OldPro
 
Village Electronics's Avatar
 
Join Date: Apr 2011
Posts: 117
Default Re: KLD-46S4100 No Picture/No Sound

Quote:
Originally Posted by shougang_wang View Post
I had the exact same brand and model number and the exact same problem.


Sony said it is out of warranty, local repair store said $75 for problem diagnosis + other fixing fees and labor.
It can easily goes to several hundreds which does not worth it.

If a guru here has some opinion, that will be really really of great help.
Would you mind sharing your opinion why a Brand name 46" LCD TV is not worth a couple of hundred dollars?
Village Electronics is offline   Reply With Quote
Old 08-23-2011, 05:32 PM   #12
shougang_wang
New Member
 
Join Date: Aug 2011
Posts: 4
Default Re: KLD-46S4100 No Picture/No Sound

with the price goes down so quickly, you can find a brand new 46 in. LCD TV ~$800.

And possibly an LED back-light one which is much lighter and thinner.

Just do a little research and wait for a deal.

Quote:
Originally Posted by Village Electronics View Post
Would you mind sharing your opinion why a Brand name 46" LCD TV is not worth a couple of hundred dollars?
shougang_wang is offline   Reply With Quote
Old 08-23-2011, 08:24 PM   #13
Village Electronics
OldPro
 
Village Electronics's Avatar
 
Join Date: Apr 2011
Posts: 117
Default Re: KLD-46S4100 No Picture/No Sound

Quote:
Originally Posted by shougang_wang View Post
with the price goes down so quickly, you can find a brand new 46 in. LCD TV ~$800.

And possibly an LED back-light one which is much lighter and thinner.

Just do a little research and wait for a deal.
I am familiar with the prices of new sets. What I am asking is why you would pay $800 instead of repair for $200 ? That is 4 times higher for a couple of years newer and the programs are the same.
Village Electronics is offline   Reply With Quote
Old 08-26-2011, 06:49 PM   #14
shougang_wang
New Member
 
Join Date: Aug 2011
Posts: 4
Default Re: KLD-46S4100 No Picture/No Sound

Hi, I have no offense. Just my personal opinion.

so here are some logic
1. This model is discontinued, on ebay, it is 599 buy it now. May be find a new one ~700.
2. with price ~800, I can buy a 47in LG LED TV which is lighter and more advance.


3. This 46S4100 model, as we can see in this forum, has a lot of problems.

someone had T-con failure, someone had A board failure, someone had power board failure.

Dig through this forum seems the problem may be bad fuse, bad connection or bad capacitors.

Most repair stores won't trace down to which part causes failure, if they found one board doesn't work. They simply buy a new one and replace the whole board instead of fix the component.


So one time fixing can easily goes to $200, parts + diagnosis+labor.

For this model if I have to fix twice in repair store, I would rather sell the good parts and buy a new one and enjoy the new technology.



Now I become a geek now, I am pretty happy to look through this forum, open the TV and trace the problem of a HDTV which I never thought of before.


Back to my question, I tested my power board.

The 12 V, 6.5 V and 3.3 V connector, which supply to A board, doesnot function.

There is no sign of burning parts, capacitor leakage, capacitor bulky etc.

Any one can have a hint of what's going on and how can I trace further?

Thanks so much.

shougang














Quote:
Originally Posted by Village Electronics View Post
I am familiar with the prices of new sets. What I am asking is why you would pay $800 instead of repair for $200 ? That is 4 times higher for a couple of years newer and the programs are the same.
Attached Images
File Type: jpg powerboard.JPG (95.0 KB, 24 views)

Last edited by shougang_wang; 08-26-2011 at 06:53 PM..
shougang_wang is offline   Reply With Quote
Old 08-29-2011, 11:19 AM   #15
serveles
New Member
 
Join Date: Aug 2011
Posts: 6
Default Re: KLD-46S4100 No Picture/No Sound

This is the trainning manual for this model maybe help you.
Attached Files
File Type: pdf Sony Kdl46s4100Training Manual.pdf (1.44 MB, 143 views)
serveles is offline   Reply With Quote
Old 08-29-2011, 04:06 PM   #16
shougang_wang
New Member
 
Join Date: Aug 2011
Posts: 4
Thumbs up Re: KLD-46S4100 No Picture/No Sound

Thank you so much.
This really really is the one that I want.



Quote:
Originally Posted by serveles View Post
This is the trainning manual for this model maybe help you.
shougang_wang is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:38 PM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?