Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting Computer Displays
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 08-01-2008, 06:01 PM   #1
ddscentral
Member
 
Join Date: Mar 2008
City & State: Vilnius
My Country: Lithuania, EU
I'm a: Professional Tech
Posts: 89
Default Bad LCD ?

I've received a 19" monitor for free, IISonic Model IIW9M.
The monitor turns on, but the video on screen is corrupted and it has a white stripe which dissappears and reappears sometimes when monitor is moved, but always remains visible in black background.
Tried opening the monitor, nothing visibly wrong. Tried reconnecting the signal cable from lcd panel to the video board. Didn't help.
All caps look ok. (but most caps are from the bad list: hermei, evercon fukkyu)
What might be wrong with this monitor ? Maybe the LCD panel itself is bad ?
ddscentral is offline   Reply With Quote
Old 08-02-2008, 07:56 AM   #2
Leopard
Senior Member
 
Join Date: Mar 2008
City & State: Finland
Posts: 101
Default Re: Bad LCD ?

Hermei? Yuck.
Evercon... GSC?! HELP!
Fuhjyyu!? OMG even worse!

Try replacing all the badcaps. Hermeis are prone to fail in LCD's and motherboards. Evercon and Fuhjyyu caps fail very often even in light-load spots.

At first I thought it could be bad solder joints judging from the moving the LCD-thing. But replace the caps first.
Leopard is offline   Reply With Quote
Old 08-02-2008, 11:02 AM   #3
kc8adu
Super Moderator
 
kc8adu's Avatar
 
Join Date: Nov 2003
City & State: dayton ohio
Posts: 7,379
Default Re: Bad LCD ?

caps are not causing this.
its a connection issue.hopefully not in the lcd module.
kc8adu is offline   Reply With Quote
Old 08-03-2008, 07:24 AM   #4
ddscentral
Member
 
Join Date: Mar 2008
City & State: Vilnius
My Country: Lithuania, EU
I'm a: Professional Tech
Posts: 89
Default Re: Bad LCD ?

Yes, that was a connection issue.
Tried slightly moving the connector from lcd to video board, the corruption is now gone, but that white stripe is still there, but only slightly visible in black background.
But I wonder how long that lcd will last with all those crap caps onboard ?
ddscentral is offline   Reply With Quote
Old 08-03-2008, 02:40 PM   #5
kc8adu
Super Moderator
 
kc8adu's Avatar
 
Join Date: Nov 2003
City & State: dayton ohio
Posts: 7,379
Default Re: Bad LCD ?

try some deoxit on the connectors.
if it clears then recap it.
kc8adu is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:36 PM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?