Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting TVs and Video Sources
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 09-15-2012, 02:02 AM   #1
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Panasonic th-p50v20a - 4 blinks (sos4)

I have a 4 blink code on P50V20A full HD about 14 months old.

Interesting fault to say the least. I isolated the SC board and the blinks changed, green led lit on the SS and managed to measure VS at 204 volts under this condition for the 3 seconds the set powered up.

When the Sc is connected 4 blinks and no led lit on that board or the SS and the set turns off straight away.

So I've headed for the SC and so far there are banks of FETs and diodes dead short all over this board.

No wonder the PSU is spitting out 4 blinks with dead shorts. The VS does not even get a raise when the SC is connected.

I checked the buffers, nothing burnt and did not find any shorts.

Here's the list and I am using the TC-P50VT20 GPF13DU Chassis service manual to fault find this as I can not find my exact model.

TH-P50V20A

SC-board TNPA5081

Board Loc# Schematic# Part# description

D482 D16482 B0FACP000003 DIODE (RFN25)
Q452 Q16452 B1JAEP000012 TRANSISTOR (45G128)
Q402 Q16402 DG3D5020CSLW TRANSISTOR (DG502LW)
Q403 Q16403 DG3D5020CSLW TRANSISTOR (DG502LW)

Q421 Q16421 DG3D4020CSRP TRANSISTOR (DG402RP)
Q660 Q16660 B1CERR000042 FET (R5007)
Q661 Q16661 B1JAER000010 TRANSISTOR (RJP63F4A)

Can any brainiacs out there help with datasheets or substitute parts? Searching is not getting me far. It's as if Panasonic use custom parts or numbers.

Very frustrating.

Last edited by tw2005; 09-15-2012 at 02:07 AM..
tw2005 is offline   Reply With Quote
Old 09-15-2012, 03:17 AM   #2
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Here's another question. Has anyone used different revisions of Sc boards to what was originally installed in their Panasonics?

I see the SC board is used on 42",46" & 50" models. having a quick look at the components there are some differences like CAPs between them but the 50" at a glance look the same.
tw2005 is offline   Reply With Quote
Old 09-15-2012, 03:27 AM   #3
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 25,991
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Can you show a picture of where the FETs show as shorted? I had a similar issue, but it was just one FET that was shorted, I was able to replace that and it worked.
__________________
Please do not PM me for help and support. Questions belong on the public forum.

65 LED/LCD TVs, 5 monitors, 25 plasma TVs, and 2 AVR 6.1 amplifiers saved from the dump!
Totally free service manuals database: http://www.toms-service-manuals.com/ (Contact me for requests or contributions.)

I have successfully fixed (from best --> worst build quality):
1 Pioneer KURO 9G, 9 Panasonic LCD/Plasma, 1 Sony LCD, 1 NEC Plasma, 2 Yamaha HTS, 4 Sharp LCDs, 5 Toshiba LCDs, 7 Philips Plasma/LCD, 1 Hitachi Plasma, 9 LG LCD/Plasma, 14 Samsung LED/LCD/Plasma, 1 Thomson Plasma, 1 Atec LCD, 1 Hanspree LCD, 1 Xerox LCD, 1 Harwa LCD, 2 Proview LCD, 2 Hyundai LCD, 1 "Onn" LCD, 1 Grundig LCD, 1 Dell LCD, 1 iiyama LCD, 1 Acer LED, 1 Logik LCD, 6 Bush LCDs, 19 Vestel LCDs
tom66 is offline   Reply With Quote
Old 09-15-2012, 03:41 AM   #4
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Quote:
Originally Posted by tom66 View Post
Can you show a picture of where the FETs show as shorted? I had a similar issue, but it was just one FET that was shorted, I was able to replace that and it worked.
Do you mean on the board, or what heat sinks they are on?
Just give me some time to work it out. There's 6 heatsinks with 9 parts off 7 of which were dead short .
tw2005 is offline   Reply With Quote
Old 09-15-2012, 04:09 AM   #5
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Sorry about the res. 7 dead shorts.

No jokes about my trendy slippers
Attached Images
File Type: jpg BAD SC PANA 50.jpg (682.5 KB, 118 views)
tw2005 is offline   Reply With Quote
Old 09-15-2012, 04:27 AM   #6
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 25,991
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

I would say it's unlikely they are all bad. You will have to remove them to test them out of circuit. Are you sure the buffers are OK, too?
tom66 is offline   Reply With Quote
Old 09-15-2012, 04:37 AM   #7
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Quote:
Originally Posted by tom66 View Post
I would say it's unlikely they are all bad. You will have to remove them to test them out of circuit. Are you sure the buffers are OK, too?
Well guess what. I did and they are dead short. hard to believe that many in different spots.

I tested gnd to the output of the buffers-no shorts. Then tested the inputs at the buffers from the sc board, no shorts either.

Any tricks you know for testing the buffers? It's not an area I'm overly confident with.

If this was a samsung ysus I'd have better luck finding components I reckon.
tw2005 is offline   Reply With Quote
Old 09-15-2012, 05:21 AM   #8
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 25,991
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

It seems very unlikely to me. How are you testing them? From source to drain, is it reading zero or almost zero?
tom66 is offline   Reply With Quote
Old 09-15-2012, 05:54 AM   #9
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Quote:
Originally Posted by tom66 View Post
It seems very unlikely to me. How are you testing them? From source to drain, is it reading zero or almost zero?
All pins are shorted no matter which way including reversing the polarity on a Fluke 73 in diode mode.

I'm talking .000. You can take my word on it. I would not believe it myself reading it but no bull. Quite incredibly strange!
tw2005 is offline   Reply With Quote
Old 09-15-2012, 06:03 AM   #10
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Quote:
Originally Posted by tw2005 View Post
All pins are shorted no matter which way including reversing the polarity on a Fluke 73 in diode mode.

I'm talking .000. You can take my word on it. I would not believe it myself reading it but no bull. Quite incredibly strange!
Ok, maybe small lie. I can get 0.01 and 0.006 but same result both polarities and more than one direction still bad IMHO. Most are .000 though.
tw2005 is offline   Reply With Quote
Old 09-15-2012, 06:25 AM   #11
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 25,991
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Try touching one probe on gate/source and the other on drain, this will ensure the FET is not being turned on by stray noise.
tom66 is offline   Reply With Quote
Old 09-15-2012, 06:41 AM   #12
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

q660 red on g/s, blk on D = .000, REVERSE =.000

Q661 IS MARKED C,G,E

Q452 IS MARKED C,G,E
Q402,Q403 IS MARKED C,G,E
Q421 IS MARKED C,G,E
D482 A,K,A
tw2005 is offline   Reply With Quote
Old 09-15-2012, 06:55 AM   #13
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 25,991
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

OK, try G-E for the "CGE" parts (they are IGBTs.)
tom66 is offline   Reply With Quote
Old 09-15-2012, 07:06 AM   #14
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Quote:
Originally Posted by tom66 View Post
ok, try g-e for the "cge" parts (they are igbts.)
q661=.000
q452=.000
q421=.000
q402=.000
q403=.000
tw2005 is offline   Reply With Quote
Old 09-15-2012, 07:34 AM   #15
tom66
Badcaps Veteran
 
Join Date: Apr 2011
City & State: Leeds (University)
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 25,991
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

So yep... they're all dead short. Something real bad must have happened. I don't know what, it might turn out better to replace the whole board.
tom66 is offline   Reply With Quote
Old 09-15-2012, 08:03 AM   #16
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Quote:
Originally Posted by tom66 View Post
So yep... they're all dead short. Something real bad must have happened. I don't know what, it might turn out better to replace the whole board.
Chicken. Where's your spirit? Dunno, I was told they were watching it and it just shutdown.

I just wish I could work out the specs but I have been lucky and a guy in the US is a liquidator with a pile of these New. Got a complete suite of boards for $115 AUD although only just ordered so won't count my chickens yet.

Obviously the main is no good here but hoping the rest matches up ok. Same panel but different SC & SS revisions but hopeful it will work.

No suggestions on what the part numbers mean for the dead components?

I've got a SC from a 42" but different component although very similar design layout.

So tempted to take pot luck with swapping the transistors but no specs so very risky.
tw2005 is offline   Reply With Quote
Old 09-15-2012, 08:03 AM   #17
kc8adu
Super Moderator
 
kc8adu's Avatar
 
Join Date: Nov 2003
City & State: dayton ohio
Posts: 7,374
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

no just one is shorted.the rest are in paralell to it.pull em all and let the dmm sort em out.
kc8adu is offline   Reply With Quote
Old 09-15-2012, 08:09 AM   #18
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Quote:
Originally Posted by kc8adu View Post
no just one is shorted.the rest are in paralell to it.pull em all and let the dmm sort em out.
What? I have 7 pulled components already out and all dead short. What's left is no longer shorted.
tw2005 is offline   Reply With Quote
Old 10-02-2012, 08:23 PM   #19
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Well boards arrived and it looks like a pig in a poke. TV still not working and now SOS6.

I guess a lost gamble. Hard to believe 2 SC board failures but replacement has no shorted fets at least.

Followed the recommended fault tree, 15V & 5V supplied at SC board. Isolated SC20 that feeds to the "A" board and C10 on the "C1" board and faults goes to SOS8.

According to the Tree, end result Replace SC board.

I'm thinking maybe component level canibalisation and getting one board good.

Any suggestions?

Still have another board coming from different vendor.

These are different revisions to my original but I still think they'll work.

Original was AF, just Tried an AP and I think the next could be AW.

Stay tuned for more giggles at my attempt to fix this.
tw2005 is offline   Reply With Quote
Old 10-02-2012, 11:22 PM   #20
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: NT
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 2,842
Default Re: Panasonic th-p50v20a - 4 blinks (sos4)

Well, up to my usual dodgey tricks. Just disabled SOS6 return to the "A" board and she's up and running. Service manual seems to have little or no voltage info.

i'll measure VAD which to chassis was nearly 200V. I may have a quick look at my P42X14A fault finding and see how it compares.

These SC boards must have some crazy bit failing to be able to still work and not burn up.

false detect?

OH, and I've earthed the SOS6 return which was sending about 4.4V. Will this destroy anything?
tw2005 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:36 PM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?