Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting Laptops & Notebooks
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 02-19-2011, 08:47 AM   #1
incradibles
Member
 
Join Date: Feb 2011
City & State: UAE
Posts: 42
Default Toshiba Satellite L300 Power Problem

I got toshiba Satellite L300, its working on battery but when i connect charger it turns off. but when i connect it to laptop without doing it on it charges battery. but without battery it doesn't work with charger.
incradibles is offline   Reply With Quote
Old 02-19-2011, 11:24 PM   #2
mattbrad2
Senior Member
 
Join Date: Jan 2011
Posts: 121
Default Re: Toshiba Satellite L300 Power Problem

Probably a Maxim or TI battery management IC acting up. If it charges, the charging circuit is fine and running off battery means the rest of the laptop is not shorted. The battery management IC controls the logic of switching between battery and AC. Look around the battery connector and see if you can find a small (~ .5") square IC labeled Maxim or TI.
mattbrad2 is offline   Reply With Quote
Old 02-20-2011, 11:11 PM   #3
incradibles
Member
 
Join Date: Feb 2011
City & State: UAE
Posts: 42
Default Re: Toshiba Satellite L300 Power Problem

Thanks for replying i will check that ic later now i got another laptop toshiba satellite A200 these 20M resistor showing Zero Ohm Resistance. laptop is dead not showing power indication, charging light nothing at all.
Attached Images
File Type: jpg 210220112245.jpg (610.4 KB, 686 views)
File Type: jpg 210220112246.jpg (595.2 KB, 528 views)
File Type: jpg 210220112247.jpg (530.4 KB, 477 views)
__________________
Silence Like Dreams
incradibles is offline   Reply With Quote
Old 02-22-2011, 05:33 PM   #4
mattbrad2
Senior Member
 
Join Date: Jan 2011
Posts: 121
Default Re: Toshiba Satellite L300 Power Problem

Did you remove those to see if they were in fact bad? They look like they've been removed. I've never seen those bad - usually its one of the neighboring mosfets or a shorted cap. If one (or more) of those are bad, they will usually give false reading on other components. The only way to tell for sure is to lift one side of the component and test it that way.
mattbrad2 is offline   Reply With Quote
Old 03-09-2011, 11:43 PM   #5
Ch1p4@ll
Newbie
 
Join Date: Mar 2010
City & State: Earth?
Posts: 15
Default Re: Toshiba Satellite L300 Power Problem

u can try to resoldering the Maxim IC (48pins) near the vga out line... it work for me before.
Ch1p4@ll is offline   Reply With Quote
Old 03-14-2011, 09:20 AM   #6
mihaicozac
New Member
 
Join Date: Mar 2011
Posts: 1
Default Re: Toshiba Satellite L300 Power Problem

20M on the resistors is in fact 20milliohm... that is likely short
for the A300:try to make short on the backup battery, for about 2-3 seconds, without power or battery on it, then attach the power plug, it should start.

Last edited by mihaicozac; 03-14-2011 at 09:23 AM..
mihaicozac is offline   Reply With Quote
Old 05-30-2011, 12:44 AM   #7
azry
New Member
 
Join Date: May 2011
Posts: 3
Default Re: Toshiba Satellite L300 Power Problem

Quote:
Originally Posted by mattbrad2 View Post
Probably a Maxim or TI battery management IC acting up. If it charges, the charging circuit is fine and running off battery means the rest of the laptop is not shorted. The battery management IC controls the logic of switching between battery and AC. Look around the battery connector and see if you can find a small (~ .5") square IC labeled Maxim or TI.
Now i hv 1 laptop same problem model L300 (pslbcl). Already check for all PQ dan PC. Please help!!
No Maxim or TI IC on my board. Can u please give the location of the IC. Thanks...
azry is offline   Reply With Quote
Old 05-30-2011, 07:42 AM   #8
ablacon64
Member
 
Join Date: Jan 2011
Posts: 85
Default Re: Toshiba Satellite L300 Power Problem

When resistor go bad, they raise the resistance, not the opposite.

Take a look at this thread:
http://www.badcaps.net/forum/showthread.php?t=8991
Posts 12 ~ 18.
ablacon64 is offline   Reply With Quote
Old 05-31-2011, 06:53 PM   #9
edpax
New Member
 
Join Date: May 2011
Posts: 2
Default Re: Toshiba Satellite L300 Power Problem

where can I buy this smd's here in the philippines? i've been to DEECO but to no avail.pls help.
edpax is offline   Reply With Quote
Old 09-28-2011, 07:16 AM   #10
zahirulislam
New Member
 
Join Date: Sep 2011
Posts: 1
Default Re: Toshiba Satellite L300 Power Problem

Quote:
Originally Posted by incradibles View Post
I got toshiba Satellite L300, its working on battery but when i connect charger it turns off. but when i connect it to laptop without doing it on it charges battery. but without battery it doesn't work with charger.

same problem to me
zahirulislam is offline   Reply With Quote
Old 09-30-2011, 03:34 AM   #11
fddizon
Badcaps Veteran
 
Join Date: Sep 2011
City & State: Forbidden
My Country: Philippines
Line Voltage: 220v 60Hz
I'm a: Knowledge Seeker
Posts: 350
Send a message via Yahoo to fddizon
Default Re: Toshiba Satellite L300 Power Problem

just a remedy,

boot your laptop using battery, go to device manager. disable the second processor.

laptop will work on charger on

fix from other forum i read
replace NEC/TOKIN chip
or Core chip regulator

hope this helps

Francis
fddizon is online now   Reply With Quote
Old 02-01-2012, 01:37 AM   #12
russell1981
Member
 
Join Date: Jan 2012
Posts: 24
Default Re: Toshiba Satellite L300 Power Problem

i have also toshiba satellite L300 power problem!but i fixed this using 4*330uf capacitor.
unfortunately 20minutes later with charger connected condition i am watching a movie then display gone.like ghost image,then its restart.and no display...!i give to heat gpu but no display.but the laptop running well,both charging light and start light is well,what is the next procedure??please help me sir.
russell1981 is offline   Reply With Quote
Old 02-04-2012, 10:45 AM   #13
russell1981
Member
 
Join Date: Jan 2012
Posts: 24
Default Re: Toshiba Satellite L300 Power Problem

i have also toshiba satellite L300 power problem!but i fixed this using 4*330uf capacitor.
unfortunately 20minutes later with charger connected condition i am watching a movie then display gone.like ghost image,then its restart.and no display...!i give to heat gpu but no display.but the laptop running well,both charging light and start light is well,what is the next procedure??please help me sir.
russell1981 is offline   Reply With Quote
Old 02-06-2012, 12:27 AM   #14
russell1981
Member
 
Join Date: Jan 2012
Posts: 24
Default Re: Toshiba Satellite L300 Power Problem

i have also toshiba satellite L300 power problem!but i fixed this using 4*330uf capacitor.
unfortunately 20minutes later with charger connected condition i am watching a movie then display gone.like ghost image,then its restart.and no display...!i give to heat gpu but no display.but the laptop running well,both charging light and start light is well,what is the next procedure??please help me sir.
russell1981 is offline   Reply With Quote
Old 02-08-2012, 12:16 PM   #15
russell1981
Member
 
Join Date: Jan 2012
Posts: 24
Default Re: Toshiba Satellite L300 Power Problem

i have also toshiba satellite L300 power problem!but i fixed this using 4*330uf capacitor.
unfortunately 20minutes later with charger connected condition i am watching a movie then display gone.like ghost image,then its restart.and no display...!i give to heat gpu but no display.but the laptop running well,both charging light and start light is well,what is the next procedure??please help me sir.
russell1981 is offline   Reply With Quote
Old 04-09-2012, 09:20 PM   #16
Madhusha
New Member
 
Join Date: Apr 2012
City & State: Colombo
My Country: Srilanka
I'm a: Knowledge Seeker
Posts: 5
Default Re: Toshiba Satellite L300 Power Problem

In my case, after replacing NEC/TOKIN chip with "330uf X4 & 220uf X2" its working fine now... thank you every one
:-)
Madhusha is offline   Reply With Quote
Old 04-16-2012, 12:58 PM   #17
Donnie5000
New Member
 
Join Date: Apr 2012
City & State: LON
My Country: UK
I'm a: Knowledge Seeker
Posts: 1
Default Re: Toshiba Satellite L300 Power Problem

Quote:
Originally Posted by Madhusha View Post
In my case, after replacing NEC/TOKIN chip with "330uf X4 & 220uf X2" its working fine now... thank you every one
:-)
Would like some more info on this, if possible.
Donnie5000 is offline   Reply With Quote
Old 04-28-2012, 01:37 AM   #18
abdulnisam
New Member
 
Join Date: Apr 2012
City & State: kerala
My Country: india
I'm a: Knowledge Seeker
Posts: 1
Default Re: Toshiba Satellite L300 Power Problem

Quote:
Originally Posted by Madhusha View Post
In my case, after replacing NEC/TOKIN chip with "330uf X4 & 220uf X2" its working fine now... thank you every one
:-)
can i use 4 tatalumic capacitor marked 330?
is that 330uF?
abdulnisam is offline   Reply With Quote
Old 04-29-2012, 07:05 AM   #19
xaviero1412
Member
 
Join Date: Apr 2009
City & State: indonesia
Posts: 60
Default Re: Toshiba Satellite L300 Power Problem

yes u can use 4x330 tantalum
xaviero1412 is offline   Reply With Quote
Old 05-04-2012, 03:35 AM   #20
sohel
New Member
 
Join Date: May 2012
City & State: Barisal
My Country: Bangladesh
I'm a: Knowledge Seeker
Posts: 1
Default Re: Toshiba Satellite L300 Power Problem

Quote:
Originally Posted by incradibles
I got toshiba Satellite L300, its working on battery but when i connect charger it turns off. but when i connect it to laptop without doing it on it charges battery. but without battery it doesn't work with charger.

same problem to me & but RAM remove then when i connect charger colling Fan runing.
sohel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:23 AM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?