Badcaps Forums

Badcaps Forums (http://www.badcaps.net/forum/index.php)
-   Troubleshooting TVs and Video Sources (http://www.badcaps.net/forum/forumdisplay.php?f=31)
-   -   emerson LC320EM9 Blinking power light (http://www.badcaps.net/forum/showthread.php?t=25711)

bobbyd40 01-19-2013 12:11 PM

emerson LC320EM9 Blinking power light
 
1 Attachment(s)
Hi green led blinks 12 times and goes off and red standby light comes on and stays on.I have posted a pic of inverter board i have checked for swollen caps and power i have no power on small ribbon cable circled in red and large black and red connector going to main board no power any suggestions?

I also replaced three diodes circled in red that i read were a problem in another post here.

bobbyd40 01-19-2013 12:51 PM

Re: emerson LC320EM9 Blinking power light
 
1 Attachment(s)
Sorry forgot to post pic of bottom here it is.

Also forgot to say that when power button pushed i hear a snap sound like a arching on or near inverter board tried to pick out exactly where it was on board but could not.

tom66 01-19-2013 12:52 PM

Re: emerson LC320EM9 Blinking power light
 
On red/black you should have approx 160V.

bobbyd40 01-19-2013 12:56 PM

Re: emerson LC320EM9 Blinking power light
 
Thanks for the quick reply

That's what i thought but i don't have any voltage there trying to figure out why.

tom66 01-19-2013 12:57 PM

Re: emerson LC320EM9 Blinking power light
 
Well that makes no sense because then you'd have no LED at all.

kevinm34232 01-19-2013 01:01 PM

Re: emerson LC320EM9 Blinking power light
 
I think because that's a pic of inverter/main board not the power supply board..

tom66 01-19-2013 01:08 PM

Re: emerson LC320EM9 Blinking power light
 
Yeah, that red/black should be 160V DC rectified from the "inverter". The "inverter" has the bridge rectifier and half of the main capacitance on it.

bobbyd40 01-19-2013 02:47 PM

Re: emerson LC320EM9 Blinking power light
 
Ok reinstalled board and checked voltage at that connector again and do have voltage there now 165 volts. But no voltages at the small ribbon cable going to main board.

budm 01-19-2013 08:27 PM

Re: emerson LC320EM9 Blinking power light
 
1 Attachment(s)
Service manual

bobbyd40 01-20-2013 06:11 AM

Re: emerson LC320EM9 Blinking power light
 
2 Attachment(s)
After a few more checks i found that if i unplug ribbon cable from inverter board to main board circled in red green power light blinks 12 times but after 12 blinks stays on and does not go out and to red standby light.

When i unplug all the connectors from main board to tcon i get no lights at all wont light up any lights. I posted pics of both sides of main board.if anyone can take a look maybe they can see something i am missing I am new to this but very interested in learning.

bobbyd40 01-20-2013 06:35 AM

Re: emerson LC320EM9 Blinking power light
 
UPDATE Tried to charge up the large cap on main board using 2 AA in series and also with 12 volts from power probe it does not charge up or read any voltage after charging. Could this be my problem?

tom66 01-20-2013 06:40 AM

Re: emerson LC320EM9 Blinking power light
 
The power supply could easily discharge it, because it works down to a very low voltage.

Along that ribbon cable you need to check each voltage on each pin and compare it to the service manual specifications.

bobbyd40 01-20-2013 07:10 AM

Re: emerson LC320EM9 Blinking power light
 
ok will check those now thanks Tom

bobbyd40 01-20-2013 07:27 AM

Re: emerson LC320EM9 Blinking power light
 
Tom i have looked at service manual but cannot find connector C501 in it that is what my connector is stamped.

tom66 01-20-2013 07:41 AM

Re: emerson LC320EM9 Blinking power light
 
Are you sure it isn't CN301, or CL1001A?

bobbyd40 01-20-2013 07:44 AM

Re: emerson LC320EM9 Blinking power light
 
Yes marked CN501 on main board side and CL1000A on inverter side.

tom66 01-20-2013 08:22 AM

Re: emerson LC320EM9 Blinking power light
 
Ah I'm being silly.
Do we have right PSU outputs? I never asked you to check...

Verify the outputs on CN301:
Pin #7, +13V
Pin #8, +24.5V
Pin #9, -6.8V
Pin #10, +3.3V
Pin #12, +3.3V
Pin #14,#15, +3.3V
Pin #16,#18,#19, +3.0V,
Pin #20, +5.0V

high-tech 01-20-2013 08:56 AM

Re: emerson LC320EM9 Blinking power light
 
Hi guys, more than once I've found a bad 1.5 amp fast recovery diode shorted on the secondary side of that multi tap transformer on the mainboard. Just a suggestion...

bobbyd40 01-20-2013 09:14 AM

Re: emerson LC320EM9 Blinking power light
 
will check psu out put voltages. Tom i just noticed a bad diode next to the transformer don't know if i fried it trying to charge up that 250 volt large cap or not will have to change it. I think i did fry it because transformer is making a high pitched noise now and did not do that before. After i get diode changed will check outputs on psu and post them .thanks again i love this site you guys are very knowledgeable on this stuff.

bobbyd40 01-20-2013 09:23 AM

Re: emerson LC320EM9 Blinking power light
 
Have diode out it is at R635 on board have to see if radio shack has one.
R635 CARBON RES. 1/4W J 270 Ω RCX4JATZ0271


All times are GMT -6. The time now is 03:24 AM.

Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.